
Computer-1
1. Computer and Its Uses

Skill Sharpeners

A.	 Click the correct option:
	 1.	 (a)	 Offices
	 2.	 (b)	 Booking tickets
	 3.	 (c)	 Desktop computer
	 4.	 (b)	 Schools
B.	 Fill the appropriate terms:
	 1.	 Computer	 2. tired
	 3.	 homework	 4. palm
C.	 True/False:
	 1. True, 2. False, 3. True, 4. False
D.	 Match the different places with 

their pictures:
	 1. (c), 2. (d), 3. (a), 4. (b)
E.	 Application based questions.
	 Rahul should use a computer, tablet 

or smartphone. These electronic 
devices allow him to run a drawing 
application and listen to song 
simultaneously.

F.	 Art Integration (For Fun)
	 Do yourself.

2. Part of Computer

Skill Sharpeners
A.	 Click the correct option:
	 1.	 (b)	 printer
	 2.	 (b)	 VDU
	 3.	 (c)	 monitor
	 4.	 (a)	 save
B.	 Fill the appropriate terms:
	 1.	 screen	 2. mouse
	 3.	 speaker	 4. printer

C.	 True/False:
	 1. False, 2. False, 3. True, 4. True
D.	 Match the following:
	 1. (b), 2. (d), 3. (a), 4. (c)
E.	 Application based question.
	 Do yourself.
F.	 Art-Integration (For Fun)

3. The Mouse

Skill Sharpeners

A.	 Click the correct option:
	 1.	 (b)	 arrow
	 2.	 (a)	 clicking
	 3.	 (b)	 pressing
	 4.	 (c)	 both of them
B.	 Fill the appropriate terms:
	 1.	 pointing	 2. single click
	 3.	 arrow	 4. scroll wheel
C.	 True/False:
	 1. False, 2. True, 3. True, 4. True
D.	 Unscramble the words and 

identify the correct word.
	 1. BUTTON, 2. MOUSE, 3. CLICK, 
	 4. SCROLL
E.	 Application based question.
	 Do yourself.
F.	 Art-Integration (For Fun)
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4. The Keyboard

Skill Sharpeners

A.	 Click the correct option:
	 1.	 (b)	 keys
	 2.	 (b)	 Enter key
	 3.	 (c)	 Backspace key
	 4.	 (a)	 Alphabet key
B.	 Fill the appropriate terms:
	 1.	 top most	 2. number
	 3.	 26	 	 4. keys
C.	 True/False:
	 1. True, 2. False, 3. True, 4. True
D.	 Match the following:

E.	 Application based questions.
	 Do yourself.
F.	 Art-Integration (For Fun)
	 Do yourself.

5. Paint

Skill Sharpeners

A.	 Click the correct option:
	 1.	 (b)	 start
	 2.	 (a)	 eraser
	 3.	 (c)	 shape
	 4.	 (a)	 drawing

B.	 Fill the appropriate terms:
	 1.	 File tab	 2. shape
	 3.	 Ribbon	 4. line
C.	 True/False:
	 1. True, 2. True, 3. False, 4. False
D.	 Match the column:
	 1. (ii), 2. (iii), 3. (iv), 4. (i)
E.	 Application based question.
	 1.	 Click on arrow below the 

brushes.
	 2.	 Different brushes will appear, 

select anyone brush.
	 3.	 Select size thickness and color 

as per your choice.
	 4.	 Drag the mouse to draw any 

picture in drawing area.
F.	 Art-Integration (For Fun)
	 Do yourself.

6. Introduction to Tux Point

Skill Sharpeners
A.	 Click the correct option:
	 1.	 (c)	 canvas
	 2.	 (b)	 paint tool
	 3.	 (a)	 quit button
	 4.	 (b)	 magic tool
B.	 Fill the appropriate terms:
	 1.	 save	 2. stamp
	 3.	 colors palatte	 4. right
C.	 True/False:
	 1. False, 2. False, 3. True, 4. False
D.	 Match the column:
	 1. (iv), 2. (i), 3. (ii), 4. (iii)
E.	 Application base question.
	 • Paint tool • Stamp tool • Lines 

tool • Shape tool • Text tool  
• magic tool • Eraser tool • New 
tool
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F.	 Art-Integration (For Fun)
	 Do yourself.

7. Drawing with AI

Skill Sharpeners

A.	 Click the correct option:
	 1.	 (b)	 man-made
	 2.	 (c)	 intelligent
	 3.	 (b)	 image
	 4.	 (c)	 artificial
B.	 Fill the appropriate terms:
	 1.	 Machine	 2. Intelligence
	 3.	 Artificial	 4. internet
C.	 True/False:
	 1. True, 2. True, 3. False, 4. False
D.	 Application based question.
	 •	 AI helps computers do things 

like to understand language, 
recognize objects in pictures, 
play games, and much more.

	 •	 Through AI, a computer can 
play, talk, and perform various 
other tasks.

	 •	 AI helps you in doing things 
faster and accurately.

E.	 Art-Integration (For Fun)
	 Do yourself.

8. Basic Computer Etiquettes

Skill Sharpeners

A.	 Click the correct option:
	 1.	 (a)	 in a queue
	 2.	 (a)	 avoid dust
	 3.	 (a)	 should not be touched
	 4.	 (a)	 save electricity
	 5.	 (a)	 to maintain cleanliness
B.	 Fill the appropriate terms:
	 1.	 silence	 2. quiet
	 3.	 electric	 4. edible

C.	 True/False:
	 1. True, 2. False, 3. True, 4. False
D.	 Match the columns:
	 1. (c), 2. (d), 3. (b), 4. (a)
E.	 Application based question:
	 •	 Remove your shoes before 

entering a computer room to 
maintain cleanliness.

	 •	 Maintain a queue to enter 
the computer room to avoid 
crowding and conflicts.

	 •	 Always keep silence inside the 
room to concentrate on your 
work.

	 •	 Computer should be covered to 
keep them clean and dust free.

	 •	 Always switch off the computer 
when not in use to avoid 
unnecessary consumption of 
electricity.

F.	 Art-Integration (For Fun)

Do's in Computer 
Room

Don't in Computer 
Room

•	Always maintain 
silence

•	Always remove 
your shoes 
before entering

•	Always switch 
off the lights, fan 
and computer 
before leaving

•	Never use 
water to clean 
computer and its 
part

•	Never bring 
eatables to the 
lab.

•	Never touch 
electrical wires 
attached to 
computer to avoid 
any mishaps.

Worksheet-1

A.	 Click the correct option:
	 1.	 (c)	 Desktop computer
	 2.	 (b)	 VDU
	 3.	 (c)	 Pressing
	 4.	 (a)	 Alphabet keys
B.	 Fill the appropriate terms:
	 1.	 26
	 2.	 pointing
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	 3.	 mouse
	 4.	 tired
C.	 Write the full form of :
	 1.	 Central Processing Unit
	 2.	 Visual Display Unit
	 3.	 Uninterruptible Power Supply
	 4.	 Electronic Mail
D.	 Label the key board :

Function keys   Alphabet keys  

Number keys

Capslock key                            Arrow key

Spacebar key     Enter key

Worksheet-2

A.	 Click the correct option:
	 1.	 (c)	 Shape
	 2.	 (a)	 quit button

	 3.	 (b)	 man-made
	 4.	 (a)	 should not be touched
B.	 Fill the appropriate terms:
	 1.	 machine
	 2.	 ruler
	 3.	 left
	 4.	 eatable
C.	 Match the column :
	 1. (c), 2. (d), 3. (a), 4. (b).
D.	 Label the components of paint :
Quick Acess 
Toolbar

      Title Bar   View Bar

File tab   
Ribbon Bar or

Toll box
 Status Bar

 

oo
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1. Exploring Desktop

Skill Sharpeners

A.	 Click the correct option:
	 1.	 (a)	 Taskbar
	 2.	 (c)	 typing
	 3.	 (b)	 taskbar
	 4.	 (a)	 resize
B.	 Fill in the blanks:
	 1.	 personalize	 2. file explorer
	 3.	 Microsoft	 4. settings app
	 5.	 Snap
C.	 True/False:
	 1. True, 2. False, 3. True, 4. True, 5. 

True
D.	 Match the following:
	 1. (iii), 2. (iv), 3. (ii), 4. (i)
E.	 Answer the following questions.
	 1.	 •	 Click on the Start button at 

the bottom-left corner of 
the screen.

	 	 •	 Scroll through the list or 
type the program's name in 
the search bar.

	 	 •	 Click on the desired 
application to open it.

	 2.	 •	 Click on the search box near 
the Start button or taskbar.

	 	 •	 Start typing the name of the 
file or app you want.

	 	 •	 Select it from the search 
results to open it.

	 3.	 Snap is a feature in Windows 
10 that helps you resize and 
arrange windows quickly. To 
use Snap:

	 	 •	 Click and drag a window to 
the elft or right edge of the 
screen.

	 	 •	 Release it when the cursor 
touches the edge.

	 	 •	 The window will snap to 
that side.

	 	 •	 You can then choose 
another window to fill the 
other help of the screen.

F.	 Art-Integration Question
	 Do yourself.

2. Working of a Computer

Skill Sharpeners
A.	 Click the correct option:
	 1.	 (a)	 electronic
	 2.	 (c)	 device
	 3.	 (b)	 Mouse
	 4.	 (c)	 Both (a) & (b)
	 5.	 (c)	 CPU
B.	 Fill in the blanks:
	 1.	 a keyboard	 2. printers
	 3.	 CPU	 4. scanner
	 5.	 small
C.	 True/False:
	 1. False, 2. False, 3. False, 4. False, 5. 

True
D.	 Match the pictures with their 

names:
	 1. (e), 2. (c), 3. (a), 4. (b), 5. (d).
E.	 Answer the following questions.
	 1.	 A device is a machine or tool 

that helps us to do work. A 
computer is also a device.

	 2.	 Storage devices are parts of a 
computer that save information 
or data.

	 	 Example: Pen drive, CD, hard 
disk, optical disk etc.
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	 3.	 Input devices are the parts of a 

computer that help us to give 
instruction to the computer.

	 	 Example: Keyboard, Mouse, 
Scanner, Microphone etc.

F.	 Art-Integration Question
	 Do yourself.

3. The Digital Backbone of 
Everyday Life

Skill Sharpeners
A.	 Click the correct option:
	 1.	 (a)	 Banks
	 2.	 (a)	 drawing
	 3.	 (c)	 ATMs
	 4.	 (c)	 medical
	 5.	 (a)	 emails

B.	 Fill in the blanks:
	 1.	 buildings, houses and towers
	 2.	 banks
	 3.	 computer
	 4. 	 satellites, rockets and missiles

C.	 True/False:
	 1. True, 2. False, 3. True, 4. True
D.	 Match the pictures with their 

names:
	 1. (e), 2. (a), 3. (d), 4. (c), 5. (b).

E.	 Answer the following questions.
	 1.	 Two uses of computer in offices 

are as follows:
	 	 •	 It helps with representations 

on some projects.
	 	 •	 It helps in sending and 

receiving emails.
	 2.	 The uses of computer in school 

are as follows:
	 	 •	 It helps in computer labs 

for conducting computer 
classes.

	 	 •	 It is used to create reports, 
time-table, activity 
calenders, circulars, etc.

	 	 •	 In the school library, to 
keep the records of books.

	 	 •	 It keeps the records of 
students.

	 3.	 •	 It helps a doctor during 
operation.

	 	 •	 It helps in the checkups, 
like eye testing.

	 	 •	 It is used for monitoring a 
patient.

	 	 •	 It helps in diagnosing many 
diseases.

	 	 •	 To keep medical records of 
patients.

F.	 Art-Integration Question
	 •	 Computers help you search for 

information quickly.
	 •	 You can watch videos and 

lessons on the computer to 
learn new things.

	 •	 You can create school projects, 
drawings and presentations on 
the computer.

	 •	 Computers help you store notes 
and homework in one place.

4. Working with Windows

Skill Sharpeners
A.	 Click the correct option:
	 1.	 (b)	 UPS
	 2.	 (a)	 icons
	 3.	 (b)	 electricity
	 4.	 (b)	 power
	 5.	 (b)	 Left Hand Side

B.	 Fill the blanks:
	 1.	 UPS	 2. search
	 3.	 wallpaper	 4. electricity
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C.	 True/False:
	 1. True, 2. False, 3. True, 4. True
D.	 Match the pictures with their 

names:
	 1. (d), 2. (c), 3. (a), 4. (b)
E.	 Answer the following questions.
	 1.	 UPS (Uninterruptible Power 

Supply) prevents the computer 
from sudden shutdowns if the 
power goes off.

	 2.	 The Windows Desktop is the 
first screen that appears when 
a computer is turned on. It 
contains icons, wallpaper and 
a taskbar, which help users 
navigate the system.

	 3.	 UPS stands for Uninterruptible 
Power Supply.

	 4.	 Wallpaper is the background 
image displayed on the desktop 
screen. Users can set any image 
as their wallpaper.

F.	 Art-Integration Question
	 Do yourself.

5. Notepad

Skill Sharpeners
A.	 Click the correct option:
	 1.	 (b)	 Text editor
	 2.	 (b)	 File
	 3.	 (b)	 Insert
	 4.	 (b)	 Font
	 5.	 (c)	 .txt
B.	 Fill in the blanks:
	 1.	 Cursor	 2. editing
	 3.	 .txt		 4. keyboard
C.	 True/False:
	 1. True, 2. False, 3. False, 4. False
D.	 Match the pictures with their 

names:

	 1. (b), 2. (d), 3. (a), 4. (c)
E.	 Answer the following questions.
	 1.	 Notepad is a text-editing 

software used for creating and 
editing plain text flies with a 
.txt extension.

	 2.	 The text starts to appear from 
the position of the cursor in the 
Notepad window.

	 3.	 No, you cannot draw pictures 
in Notepad because it is a 
plain text editor and does not 
support images or graphics.

F.	 Art-Integration Question
	 Example of 10-line eassay:
	 My School
•	 My school is a place where I learn 

new things every day.
•	 The teachers in my school are very 

kind and helpful.
•	 I have many friends in my school.
•	 We study different subjects like 

English, Math, and Science.
•	 Our school has a big playground 

where we play games.
•	 The school also has a library with 

many books.
•	 We celebrate different festivals and 

events in school.
•	 Our school teaches us discipline 

and good manners.
•	 The classrooms are clean and have 

a good learning environment.
•	 I love my school very much!

6. Wordpad

Skill Sharpeners

A.	 Click the correct option:
	 1.	 (c)	 typing
	 2.	 (c)	 title bar
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	 3.	 (c)	 quick access
	 4.	 (b)	 double
	 5.	 (a)	 bold
B.	 Complete the spelling:
	 1.	 Font
	 2.	 Ribbon
	 3.	 Cursor
	 4.	 Underline
C.	 True/False:
	 1. True, 2. True, 3. False, 4. True
D.	 Match the pictures with their 

names:
	 1. (d), 2. (a), 3. (b), 4. (c)
E.	 Answer the following questions.
	 1.	 WordPad is a text-editing 

program that allows users to 
type, format, and edit text. It 
provides basic text formatting 
features like bold, italic, 
underline, font size, and font 
color.

	 2.	 •	 To select a single word → 
Double-click the word.

	 	 •	 To select a single paragraph 
→ Triple-click a word 
within the paragraph or 
double-click in the margin 
to the left of the paragraph.

	 	 •	 To select any part of the 
document → Click at the 
beginning, press and hold 
Shift, then click at the end.

	 	 •	 To select the entire 
document →Triple-click in 
the left margin, press Ctrl 
+ A, or use the "Select All" 
button on the Home tab.

	 3.	 •	 Method 1: Click the Close 
(X) button on the top right 
of the WordPad window.

	 	 •	 Method 2: Click on the Exit 
option in the File menu.

F.	 Art-Integration Question
	 Do yourself.

7. Tux Typing

Skill Sharpeners

A.	 Click the correct option:
	 1.	 (b)	 Penguin
	 2.	 (c)	 Learn to type
	 3.	 (b)	 Random words
	 4.	 (a)	 Space bar
B.	 Fill in the blanks:
	 1.	 typing	 2. falling 

latters
	 3.	 keyboard	 4. sky
	 5.	 computer
C.	 Match the column:
	 1. (b), 2. (a), 3. (d), 4. (c)
D.	 Answer the following questions.
	 1.	 The name of the penguin in Tux 

Typing is Tux.
	 2.	 When you type words 

correctly, you catch falling 
letters or words.

	 3.	 Playing Tux Typing helps you 
improve your typing speed, 
accuracy, and familiarity with 
the keyboard while making 
learning fun.

	 4.	 Letters or words fall from the 
sky,and you must type them 
correctly.

E.	 Art-Integration Question
	 Do yourself.

Worksheet-1
A.	 Click the correct option:
	 1.	 (a)	 Taskbar
	 2.	 (a)	 electronic
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	 3.	 (a)	 Banks
	 4.	 (b)	 UPS
B.	 Fill the appropriate terms:
	 1.	 personalize
	 2.	 keyboard
	 3.	 graphics
	 4.	 UPS
C.	 True/False :
	 1. T, 2. F, 3. T, 4. T
D.	 Match the following:
	 1. (c), 2. (d), 3 (b), 4. (a).
E.	 Answer the following question :
	 1.	 •	 Click on the start button at 

the bottom left corner of 
the screen.

	 	 •	 Scroll through the list or 
type the program's name in 
the search bar.

	 	 •	 Click on the desired 
application to open it.

	 2.	 Storage devices are the parts 
of a computer that save 
information or data.

	 	 Example : Pen drive, CD, hard 
disk, optical disk, etc.

	 3.	 •	 It help a doctor during 
operation.

	 	 •	 It helps in the checkups, 
like eye testing.

	 	 •	 It is used for monitoring a 
patient.

	 	 •	 It helps in diagnosing many 
diseases.

	 	 •	 To keep medical records of 
patients.

	 4.	 UPS (Uninterruptible Power 
Supply) prevents the computer 
from sudden shutdowns if the 
power goes off.

Worksheet-2
A.	 Click the correct option:
	 1.	 (a)	 Text editor
	 2.	 (c)	 typing
	 3.	 (b)	 Penguin
	 4.	 (c)	 Learn to type
B.	 Fill in the blanks:
	 1.	 cursor
	 2.	 editing
	 3.	 typing
	 4.	 falling letters
C.	 True / False :
	 1. T, 2. T, 3. T, 4. F.
D.	 Match the following :
	 1. (b), 2. (d), 3. (a), 4. (c).
E.	 Answer the following question :
	 1.	 Notepad is a text editing 

software used for creating and 
editing plain text files with a 
.txt extension.

	 2.	 WordPad is a text-editing 
program that allows users to 
type, format and edit text. It 
provides basic text formatting 
features like bold, italic, 
underline, font size and font 
color.

	 3.	 The name of the penguin in Tux 
Typing is Tux.

oo



Computer-3
1. Working of Computer

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (b)	 Input
	 2.	 (b)	 hard disk
	 3.	 (b)	 CPU
	 4.	 (b)	 Drawing
	 5.	 (a)	 output
B.	 Fill in the blanks:
	 1.	 devices
	 2.	 hardware
	 3.	 ALU
	 4.	 WordPad
C.	 Match the following words with 

their associated field in computer:
	 1. (b), 2. (d), 3. (a), 4. (e), 5. (c)
D.	 Tick () the correct statements and 

cross () out the wrong ones.
	 1. (), 2. (), 3. (), 4. ().
E.	 Answer the following questions.
	 1.	 Input is the data or instruction 

given to a computer.
	 2.	 Output is the result generated 

by a computer after processing 
the input.

	 3.	 The CPU is the primary 
component of a computer 
that executes instruction 
from software and performs 
arithmetic, logic, control and 
input/output operations as 
specified by these instructions.

	 4.	 Input devices provide the 
data and instructions to the 
computer. Output devices 
display or produce the results 
of the processing done by the 
computer.

	 5.	 Computer hardware refers to 
the physical components of a 
computer system, such as the 

CPU, motherboard, RAM and 
input/output devices.

F.	 Art Integration
	 Do yourself.

2. Introduction of Windows 10

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 Bottom
	 2.	 (c)	 Both
	 3.	 (a)	 Cortana
	 4.	 (c)	 Both
B.	 Fill in the blanks:
	 1.	 operating system
	 2.	 graphics
	 3.	 wallpaper
	 4.	 ribbons
C.	 Match the following words 

with   associated with the field of 
computer:

	 1. (d), 2. (c), 3. (a), 4. (b).
D.	 Answer the following questions.
	 1.	 A software that manages entire 

system is known as operating 
system.

	 	 The names of some operating 
system are windows, chrome 
OS, Mac OS, Linux and 
Android.

	 2.	 Cortana voice search is a feature 
in windows that lets you search 
for things on your computer or 
the internet by speaking.

	 3.	 System tray is located on the 
right-hand side of the task bar. 
It shows icons for programs 
that are running quietly in the 
background, such as Antivirus.

	 4.	 Working area is a large are 
located in the centre of the 
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window. Our work, such as 
drawing or text are shown in 
the working area.

E.	 Art Integration
	 Do yourself.

3. Working with Files and 
Folders

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 Yellow
	 2.	 (a)	 Video
	 3.	 (c)	 MS paint
	 4.	 (a)	 File
B.	 Fill in the blanks:
	 1.	 audio	 2. image
	 3.	 desktop	 4. files
C.	 Match the following words 

with   associated with the field of 
computer:

	 1. (d), 2. (b), 3. (a), 4. (c).
D.	 Tick () the correct statements and 

cross () out the wrong ones.
	 1. (), 2. (), 3. (), 4. ().
E.	 Answer the following questions.
	 1.	 Content is right hand side part. 

This large area displays the 
contents of the folder or drive 
selected on the left side.

	 2.	 Folders are used to store and 
organize files on a computer.

	 3.	 To save files in a desired folder:
	 	 Step 1 : File → Save
	 	 Step 2 : In the Save As dialog 

box, click on D : drive.
	 	 Step 3 : Double click on the 

picture folder.
	 	 Step 4 : Type the name of the 

file. Click on the Save button.
	 4.	 Yes, different files need 

different programs to open.
	 	 For example :
	 	 •	 A picture file (.jpg) opens in 

MS Paint.
	 	 •	 A document file (.docx) 

opens in MS Word.
	 	 •	 A song file (.mp3) opens in 

a music player.
F.	 Art Integration
	 Do yourself.

4. Computer Softwares

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 Software
	 2.	 (c)	 Both
	 3.	 (b)	 MS PowerPoint
	 4.	 (b)	 MS DOS
B.	 Fill in the blanks:
	 1.	 Mac OS
	 2.	 system
	 3.	 single user
	 4.	 multi-user
C.	 Tick () the correct statements and 

cross () out the wrong ones.
	 1. (), 2. (), 3. (), 4. ().
D.	 Answer the following questions.
	 1.	 (1)	 CorelDRAW Graphics 

Suite
	 	 (2)	 Adobe CS
	 2.	 A multi-user operating system 

allows more than one person to 
use the computer at the same 
time.

	 3.	 GUI : Graphical User Interface
	 	 CUT : Character User Interface
	 4.	 (1) MS DOS  (2) Windows 10
F.	 Art Integration
	 Do yourself.

5. Getting Started with Microsoft 
Word 2021

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (a)	 Track changes
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	 2.	 (a)	 Home
	 3.	 (b)	 Ctrl + Enter
B.	 Fill in the blanks:
	 1.	 word processing
	 2.	 Calculator
	 3.	 clipboard
	 4.	 mail merge

C.	 Tick () the correct statements and 
cross () out the wrong ones.

	 1. (), 2. (), 3. (), 4. (), 5. ().

D.	 Answer the following questions.
	 1.	 In MS word 2021, we can work 

with paragraphs by using the 
Home tab.

	 	 We can :
	 	 •	 Align text (Left, Cente, 

Right, Justify)
	 	 •	 Change line spacing
	 	 •	 Add bullets or numbers
	 	 •	 Increase or decrease indent
	 2.	 Click on the Insert tab. You can 

insert :
	 	 • pictures • Shapes • Tables • 

WordArt • Charts • Text Boxes
	 3.	 To save a document :
	 	 Step 1 : Click on the File tab.
	 	 Step 2 : Select Save or Save As.
	 	 Step 3 : Choose the location 

and enter a file name.
	 4.	 To create a new document :
	 	 Step 1 : Click on the File tab in 

the Ribbon.
	 	 Step 2 : Select New from the 

menu.
	 	 Step 3 : Choose a blank 

document or select a template 
from the available options.

	 5.	 Bold : Ctrl + B
	 	 Italic : Ctrl + I
	 	 Underline : Ctrl + U
E.	 Art Integration

	 Do yourself.

6. Computer Language

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 Language
	 2.	 (c)	 Translator
	 3.	 (c)	 Machine Language
	 4.	 (b)	 Google
B.	 Fill in the blanks:
	 1.	 PHP
	 2.	 Assembly
	 3.	 High
	 4.	 loader
C.	 Tick () the correct statements and 

cross () out the wrong ones.
	 1. (), 2. (), 3. (), 4. ().
D.	 Answer the following questions.
	 1.	 Low-Level Language, also 

known as machine language 
or machine code, is the lowest 
level programming language 
understood by computers.

	 2.	 A compiler translates the entire 
source code of a program 
written in a high-level language 
(like C, C++, Java) into machine 
code (binary code) that the 
computer's CPU can directly 
execute.

	 3.	 The two advantages of high-
level language are :

	 	 (1)	 Abstraction : High-
level languages provide 
abstraction that allow 
programmers to focus more 
on the logic of the program 
rather than the specific 
details of the hardware. 
This abstraction simplifies 
programming tasks and 
reduces the complexity of 
writing code.

	 	 (2)	 Productivity : High-level 
languages are designed 
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to be more expressive 
and require fewer lines of 
code to accomplish tasks 
compared to low-level 
languages. This improves 
programmer productivity 
and reduces development 
time.

	 4.	 Translator in the context of 
computers refer to software tools 
that converts programs written 
in one programming language 
or representation into another 
form that can be executed by the 
computer.

E.	 Art Integration
	 Do yourself.

7. Fun with Scratch

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (c)	 Program	 2. (c) Both
	 3.	 (c)	 Stage	 4. (c) Blocks
	 5.	 (b)	 360 degrees
B.	 Fill in the blanks:
	 1.	 Scratch	 2. Motion
	 3.	 Script	 4. Block
C.	 Match the following columns.
	 1. (b), 2. (c), 3. (a), 4. (d).
D.	 Tick () the correct statements and 

cross () out the wrong ones.
	 1. (), 2. (), 3. (), 4. (), 5. ().
E.	 Answer the following questions.
	 1.	 Instructions or sets of 

instructions given to computers 
to perform task is called 
programming. Programming is 
a stepwise process.

	 2.	 Stage is the area where we see 
the animation or action of the 
Sprite.

	 3.	 We can add add a Backdrop by 
clicking the choose Backdrop 
button and selecting or drawing 
a new one.

	 4.	 We learn how to create 
animations, stories, and games 
using blocks of code.

	 5.	 Turn clockwise (clockwise 
means the direction in which 
hands of a clock move).

	 	 •	 Turn anticlockwise (it 
means the opposite 
direction to the hands of a 
clock).

	 	 •	 Point the Sprite up, down, 
left or right.

F.	 Art Integration
	 Do yourself.

Worksheet-1
A.	 Click the correct option:
	 1.	 (b)	 hard disk
	 2.	 (b)	 Bottom
	 3.	 (a)	 Video
	 4.	 (b)	 MS DOS
B.	 Fill the appropriate terms:
	 1.	 devices
	 2.	 graphics
	 3.	 desktop
	 4.	 multi-user
	 5.	 clipboard
C.	 True / False :
	 1. T, 2. F, 3. T, 4. F. 5. F.
D.	 Match the following words with 

their associated field in computer :
	 1. (b),  2. (d), 3. (a), 4. (e), 5. (c)
E.	 Answer the following questions.
	 1.	 The full form of I-P-O is Input-

Processing-Output.
	 2.	 Cortana voice search is a feature 

in windows that lets you search 
for things on your computer or 
the internet by speaking.

	 3.	 To save files in a desired folder:
	 	 Step 1: File → Save
	 	 Step 2 : In the Save As dialog 

box, click on D: Drive.
	 	 Step 3: Double click on the 
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picture folder.

	 	 Step 4: Type the name of the 
file. Click on the save button.

	 4.	 1. MS DOS 2. Windows 10
	 5.	 Bold : Ctrl + B; Italic : Ctrl + I;  

Underline : Ctrl + U.
	 6.	 The two advantages of high-

level language are :
	 	 (1)	 Abstraction : High-

level languages provide 
abstraction that allow 
programmers to focus more 
on the logic of the program 
rather than the specific 
details of the hardware. 
This abstraction simplifies 
programming tasks and 
reduces the complexity of 
writing code.

	 	 (2)	 Productivity : High-level 
languages are designed 
to be more expressive 
and require fewer lines of 
code to accomplish tasks 
compared to low-level 
languages. This improves 
programmer productivity 
and reduces development 
time.

	 7.	 •	 Turn clockwise (Clockwise 
means the direction in 
which hands of a clock 
move)

	 	 •	 Turn anticlockwise (it 
means the opposite 
direction to the hands of a 
clock)

	 	 •	 Point the sprite up, down, 
let or right)

Worksheet-2
A.	 Click the correct option:
	 1.	 (a)	 Track changes
	 2.	 (b)	 Language

	 3.	 (c)	 Program
	 4.	 (a)	 Home
B.	 Fill the appropriate terms:
	 1.	 word processing
	 2.	 PHP
	 3.	 Assembly
	 4.	 Scratch
	 5.	 Calculators
C.	 True / False :
	 1. F, 2. F, 3. T, 4. T, 5. F.
D.	 Match thefollowing columns :
	 1. (b), 2. (c), 3. (a), 4. (d).
E.	 Answer the following questions.
	 1.	 In MS Word 2021, we can work 

with paragraphs by using the 
Home tab : we can :

	 	 •	 Align text (Centre, Left, 
Right, Justify)

	 	 •	 Change line spacing, add 
bullets or numbers

	 	 •	 Increase or decrease indent
	 2.	 Low level language, also 

known as machine language 
or machine code, is the lowest-
level programming language 
understood by computers.

	 3.	 Instructions or set of 
Instructions given to computers 
to perform task is called 
programming. Programming is 
a stepwise progress.

	 4.	 Translator in the context of 
computers refer to software 
tools that converts programs 
written in one programming 
language or representation 
into another form that can be 
executed by the computer.

	 5.	 We can add a backdrop by 
clicking the choose backdrop 
button and selecting or drawing 
a new one.

oo
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1. Multimedia on Computer 

Using Windows 10
Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (c)	 Groove Music
	 2.	 (b)	 Spreadsheet
	 3.	 (b)	 Play audio and video files
	 4.	 (c)	 Adobe Photoshop
B.	 Fill in the blanks:
	 1.	 Auto Play	 2. video
	 3.	 manage, manipulate
	 4.	 Update	 5. Auto Play
C.	 True or False:
	 1.	 True	 2. True
	 3.	 False	 4. False
D.	 Match the columns:
	 1. (b), 2. (a), 3. (d), 4. (c)
E. Very Short Answer Type Questions:
	 1.	 Entertainment and Education
	 2.	 Auto Play
	 3.	 Groove Music
	 4.	 To play audio and video files
F.	 Short Answer Type Questions:
	 1.	 The process of installing a 

multimedia CD-ROM on 
windows 10 are as follows:

              Step 1 : Insert the CD-ROM
	 	 (i)	 Open the CD/DVD drive on 

your computer by pressing 
the drive's eject button.

	 	 (ii)	 Place the multimedia CD-
ROM into the drive and 
close it.

	 	 Step 2 : Install the software
	 	 (i)	 Windows 10 should 

automatically recognize 

the CD-ROM and displays 
a notification. If it doesn't, 
go to file explorer and open 
the CD/DVD drive.

	 	 (ii)	 Locate and double click 
the setup.exe or install.exe 
file on the CD-ROM. This 
will start the installation 
process.

	 	 (iii)	Follow the on-screen 
instructions provided by 
the installation wizard. 
This usually involves 
agreeing to the license 
terms, selecting installation 
options, and choosing a 
directory for installation.

	 	 (iv)	Once installation is 
complete, you might need 
to restart your computer.

	 2.	 Multimedia helps in 
creating interactive learning 
environments. Educational 
software and videos make 
complex subjects easier to 
understand.

	 3.	 Groove music is a built-in 
music player in windows 10. 
Open Groove Music from the 
start Menu and drag and drop 
the music file into the player.

	 4.	 In education, Multimedia helps 
in creating interactive learning 
environments. Educational 
Software and videos make 
complex subjects easier to 
understand.

	 	 In entertainment, Multimedia 
content like movies, music and 
games provides relaxation and 
enjoyment.
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Art Integration
	 1.	 By combining images, 

animations, and audio using 
software like Photoshop and 
video editors to produce a 
creative visual presentation.

	 2.	 Multimedia can add videos, 
images, animations, and sound 
effects to make historical events 
more vivid, engaging and 
memorable.

2. Windows 10 Settings
Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (c)	 Personalization
	 2.	 (c)	 Colors in Personalization
	 3.	 (c)	 video
	 4.	 (b)	 Lock Screen
	 5.	 (b)	 Time & Language
B.	 Fill in the blanks:
	 1.	 Settings	 2. Background
	 3.	 Slide show	 4. Change
	 5.	 Fonts
C.	 True or False:
	 1.	 False	 2. True
	 3.	 False	 4. True
	 5.	 False

D.	 Match the columns:
	 1. (b), 2. (c), 3. (a), 4. (d)

E. Very Short Answer Type Questions:

	 1.	 You can find the option to 
change the screen saver in 
settings > personalization > 
Lock Scren > Screen Saver 
settings.

	 2.	 The section in the settings app 
that allows you to change the 
window color is settings > 
personalization > colors.

	 3.	 •	 Click the start button on the 
task bar.

	 	 •	 Scroll down and select the 
settings app.

	 4.	 Picture, solid color and slide 
show.

	 5.	 By toggling the switch set time 
automatically in the date & 
Time settings.

F.	 Short Answer Type Questions:
	 1.	 To change the desktop 

background in windows 10 :
	 	 •	 Click on the start menu and 

select settings.
	 	 •	 Click on Personalization in 

the settings window.
	 	 •	 In the left-hand menu, 

select background.
	 	 •	 From the drop down menu, 

select Picture, solid color or 
slide show.

	 	 •	 Browse and select your 
desired image or color and 
apply the settings.

	 2.	 To costomize the window color 
in windows 10 :

	 	 •	 Click on the start menu and 
select settings.

	 	 •	 Click on personalization.
	 	 •	 In the left hand menu, 

select colors.
	 	 •	 Select a color from the 

palette or choose custom 
color for more options.

	 	 •	 Toggle the switch for Title 
bars and window borders 
to apply the color to these 
elements.

	 3.	 To set the date and time 
manually in windows 10 :

	 	 •	 Click on the start menu and 
select settings.
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	 	 •	 Click on Personalization.
	 	 •	 In the left-hand menu, 

select Date and Time.
	 	 •	 Click change to manually 

set the date and time.
	 4.	 To apply a screen saver in 

windows 10 :
	 	 •	 Click on the start menu and 

select settings.
	 	 •	 Click on Personalization.
	 	 •	 In the left hand menu, 

select lock screen.
	 	 •	 Scroll down and click on 

screen saver settings.
	 	 •	 Select a screen saver from 

the drop down menu and 
configure its settings.

	 	 •	 Click apply and then OK to 
save your changes.

	 5.	 To change the display theme in 
windows 10:

	 	 •	 Click on the start menu and 
select settings.

	 	 •	 Click on Personalization.
	 	 •	 In the left-hand menu, 

select themes.
	 	 •	 Select a theme from the 

available options or click 
Get More Themes in 
Microsoft store for addition 
choices.

Art Integration
	 Do yourself.

3. Windows 10 : Working with 
Files and Folders

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (c)	 Click on the File Explorer 

icon on the task bar.
	 2.	 (b)	 Ctrl + C

	 3.	 (c)	 Recycle Bin
	 4.	 (a)	 Right-Click and select New 

> Folder
	 5.	 (a)	 Cut and Paste
B.	 Fill in the blanks:
	 1.	 double-click	 2. This PC
	 3.	 Recycle Bin	 4. Ctrl
	 5.	 Recycle Bin
C.	 True or False:
	 1.	 True	 2. True
	 3.	 False	 4. False
	 5.	 True

D.	 Match the columns:
	 1. (b), 2. (d), 3. (a), 4. (e), 5.  (c).

E. Very Short Answer Type Questions:
	 1.	 To temporarily store deleted 

files until they are permanently 
removed or restored.

	 2.	 •	 Click on the File Explorer 
icon on the taskbar or press 
Windows + E.

	 	 •	 Select Thic PC. In the left-
hand pane, click on This 
PC.

	 3.	 Ctrl + X.
	 4.	 The copied file is pasted in the 

selected location.
	 5.	 •	 Use File Explorer to 

navigate to the location 
where you want to create a 
new folder.

	 	 •	 Right-click and select New 
> Folder from the context 
menu.

	 	 •	 Enter a name for the new 
folder and press Enter.

F.	 Short Answer Type Questions:

	 1.	 To delete a file in windows 10 :
	 	 •	 Click on the file you work 

to delete.
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	 	 •	 Press the delete key on 

your keyboard or right-
click and select delete from 
the context menu.

	 	 •	 Confirm the deletion if 
prompted.

	 	 To restore deleted file from the 
Recycle Bin :

	 	 •	 Double-Click on Recycle 
Bin icon on the Desktop.

	 	 •	 Click on the files you want 
to delete.

	 	 •	 Right-click and select 
Restore or click Restore 
the selected items in the 
toolbar. The items will be 
restored to their original 
location.

	 2.	 To move a file from one folder 
to another :

	 	 •	 Click on the file you want 
to move.

	 	 •	 Press Ctrl + X or right click 
and select cut.

	 	 •	 Navigate to the location 
where you want to move 
the file.

	 	 •	 Press Ctrl + V or right-click 
and select Paste.

	 3.	 To create a new text document 
in a specific folder :

	 	 •	 Use File Explorer to 
navigate to the location 
where you want to create a 
desired folder.

	 	 •	 Right-click on an empty 
area in the folder.

	 	 •	 Select New → Text 
Document.

	 	 •	 Enter a name for the new 
folder and press Enter.

	 4.	 To select multiple files at once 
in File Explorer :

	 	 Hold down the Ctrl key and 
click on each file you want to 
select. Alternatively, click and 
drag to draw a selection box 
around multiple files.

Art Integration
	 Do yourself.

4. Edit and Format Word 
Documents

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (c)	 Ctrl + C
	 2.	 (b)	 Press Ctrl + H
	 3.	 (c)	 Review tab
	 4.	 (b)	 X2

	 5.	 (c)	 Reverse the last action
B.	 Fill in the blanks:
	 1.	 Home
	 2.	 Thesaurus
	 3.	 Ctrl + V
	 4.	 Text Hightlight Color
	 5.	 Redo
C.	 True or False:
	 1.	 True	 2. False
	 3.	 False	 4. False
	 5.	 True
D.	 Match the columns:
	 1. (d), 2. (b), 3. (a), 4. (c), 5.  (e).
E.	 Very Short Answer Type 

Questions:
	 1.	 Ctrl + Z
	 2.	 Home tab > Font dropdown
	 3.	 Select Text > Home > Superscript
	 4.	 Finds and replaces words or 

phrases
	 5.	 Review tab
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F.	 Short Answer Type Questions:
	 1.	 Copying text means making a 

duplicate of it to use somewhere 
else.

	 	 Steps:
	 	 1.	 Select the Text: Click and 

drag your mouse over the 
text you want to copy.

	 	 2.	 Copy the Text: Press Ctrl 
+ C on your keyboard or 
right-click and choose 
Copy.

	 	 3.	 Paste the Text: Place your 
cursor where you want to 
paste the copied text and 
press Ctrl + V or right-click 
and choose Paste.

	 2.	 The Thesaurus helps you find 
synonyms (words with similar 
meanings) and antonyms 
(words with oposite meanings).

	 	 Steps:
	 	 1.	 Select the Word: Highlight 

the word you want to find 
a synonym for.

	 	 2.	 Open Thesaurus: Right-
click the word and choose 
Synonyms or go to the 
Review tab and click 
Thesaurus.

	 	 3.	 Choose a Synonym: Select 
a synonym from the list to 
replace the original word.

	 3.	 Changing the font size helps 
make your text more readable 
or eye-catching.

	 	 Steps:
	 	 1.	 Select the Text: Highlight 

the text you want to resize.
	 	 2.	 Open Font Size Options: 

Go to the Home tab and 
use the Font Size drop-

down menu.
	 	 3.	 Choose a Size: Select a 

size from the list or type a 
specific number.

	 4.	 The Spelling and Grammar 
check feature helps you find 
and correct mistakes in your 
document.

	 5.	 Highlighting adds a 
background color to text, 
helping it stand out.

	 	 Steps:
	 	 1.	 Select the Text: Select the 

text you want to highlight.
	 	 2.	 Open Highlight Options: 

Go to the Home tab and 
click the Text Highlight 
Color button.

	 	 3.	 Choose a color: Pick a 
highlight color from the 
palette.

Art Integration
	 Create a colorful flyer in Microsoft 

Word to invite your friends to an 
imaginary "Art Festival".

	 •	 Use Bold, Italics, Font Color 
and Font Size for the title.

	 •	 Add shapes or images for 
decoration.

	 •	 Choose a background color.
	 •	 Experiment with text alignment 

and borders to make it vibrant.

5. Text Enhancement in  
MS Word 2021

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (c)	 Align Left
	 2.	 (b)	 Click the "Bullets" button
	 3.	 (a)	 Home tab
	 4.	 (c)	 Home
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	 5.	 (b)	 Design tab > Watermark
B.	 Fill in the blanks:
	 1.	 Numbering	 2. Layout
	 3.	 Watermark	 4. Home
	 5.	 Center
C.	 True or False:
	 1.	 False	 2. False
	 3.	 True	 4. True
	 5.	 True
D.	 Match the columns:
	 1. (d), 2. (e), 3. (a), 4. (b), 5.  (c).
E.	 Very Short Answer Type 

Questions:
	 1.	 It aligns the text evently on 

both the left and right margins.
	 2.	 In the Home tab.
	 3.	 To show a faint background 

text or image behind the 
document content.

	 4.	 In the Layout tab and the Home 
tab (for line spacing).

	 5.	 Go to the Home tab, click the 
Borders button, and choose a 
border option.

F.	 Short Answer Type Questions:
	 1.	 Go to the Design tab > Click on 

Watermark > Select "Custom 
Water-mark" > Choose Text or 
Picture > Apply.

	 2.	 "Align Left" positions text 
along the left margin; "Center" 
aligns text in the midle of the 
page.

	 3.	 To apply Page Borders and 
Shading in a document:

	 	 Steps:
	 	 1.	 Open Page Borders: Go to 

the Design tab and click the 
Page Borders button.

	 	 2.	 Choose Border Style: In 

the Borders and Shading 
dialog box, select your 
desired style.

	 	 Steps to Add Page Shading
	 	 1.	 Open Page Color Options: 

Go to the Design tab and 
click the Page color button.

	 	 2.	 Choose a Shading Color: 
Select a color from the 
palette to apply it to the 
entire page.

	 4.	 Text alignment refers to how 
text is positioned within 
the document. MS Word 
2021 provides the following 
alignment options:

	 	 •	 Align Left
	 	 •	 Center
	 	 •	 Align Right
	 	 •	 Justify (aligns text evenly 

on both sides)
	 5.	 Steps to add a Watermark:
	 	 1.	 Open Watermark Options: 

Go to the Design tab and 
click the Watermark button.

	 	 2.	 Choose a Watermark: Select 
a predefined watermark or 
click 'Custom Watermark' 
to create your own.

Art Integration
	 Do yourself.

6. Working with Graphics in  
MS Word 2021

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 Drag the corner handles
	 2.	 (b)	 Picture Format tab
	 3.	 (b)	 Insert tab
	 4.	 (a)	 Insert tab > 3D Models
	 5.	 (c)	 To apply visual effects like 
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shadows and glows to 
shapes

B.	 Fill in the blanks:

	 1.	 Picture Format

	 2.	 Insert

	 3.	 Shape Format

	 4.	 WordArt

	 5.	 Delete

C.	 True or False:

	 1.	 False

	 2.	 False

	 3.	 True

	 4.	 True

	 5.	 False

D.	 Match the columns:

	 1. (c), 2. (e), 3. (d), 4. (a), 5.  (b).

E. Very Short Answer Type Questions:

	 1.	 Go to the Picture Format tab 
and click the Crop button.

	 2.	 It controls how text flows 
around the picture.

	 3.	 Go to Insert tab > Click Shapes 
> Choose and draw a shape.

	 4.	 Design tab > Watermark

	 5.	 Right-click the shape and select 
"Add Text" or simply type 
inside the shape.

F.	 Short Answer Type Questions:

	 1.	 Adjusting the size of a picture 
ensures it fits well with your 
document layout.

	 	 1.	 Select the Picture: Click on 
the picture you want to 
resize.

	 	 2.	 Resize Handles: Drag the 
corner handles to maintain 
the picture's aspect ratio, 
or drag the side handles to 

resize without maintaining 
the ratio.

	 	 3.	 Use the Format Tab: For 
precise resizing, go to the 
"Picture Format" tab and 
enter exact dimensions in 
the "Size" group.

	 2.	 Inserting 3D Models
	 	 1.	 Insert 3D Model: Go to the 

"Insert" tab and click "3D 
Models."

	 	 2.	 Choose Model: Select 
"Stock 3D Models" or 
"From a File."

	 	 3.	 Insert Model: Browse, 
select, and insert the 3D 
Model.

	 3.	 You can customize the 
appearance of your shapes with 
various formatting options.

	 	 1.	 Select the Shape: Click 
on the shape you want to 
format.

	 	 2.	 Format Shape: Go to the 
"Shape Format" tab and 
use options like "Shape 
Fill." "Shape Outline," 
and "Shape Effects" to 
customize the shape.

	 4.	 Remove unwanted WordArt 
from your document.

	 	 1.	 Select WordArt: Click on 
the WordArt you want to 
delete.

	 	 2.	 Delete WordArt: Press the 
"Delete" key or right-click 
and select "Cut."

	 5.	 Add effects like shadows, 
reflections, and glows to your 
shapes.

Art Integration
	 Do yourself.
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7. Google Docs - An Introduction
Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 Writing and editing 

documents
	 2.	 (b)	 Google Drive
	 3.	 (b)	 Go to Insert > Image
	 4.	 (b)	 It saves automatically
	 5.	 (b)	 Share button
B.	 Fill in the blanks:
	 1.	 Google Drive	 2. Share
	 3.	 Insert	 4. Google
	 5.	 Tables
C.	 True or False:
	 1.	 True	 2. False
	 3.	 True	 4. False
	 5.	 True
D.	 Match the columns:
	 1. (c), 2. (a), 3. (d), 4. (b), 5.  (e).
E. Very Short Answer Type Questions:
	 1.	 Google Docs is a free online 

word processor to write, edit, 
and share documents.

	 2.	 Google Docs files are saved in 
Google Drive.

	 3.	 It saves automatically every 
few seconds.

	 4.	 The Share button.
	 5.	 The Insert menu.
F.	 Short Answer Type Questions:
	 1.	 Two advantages of using 

Google Docs are:
	 	 •	 It is free and works on any 

device.
	 	 •	 It automatically saves your 

work every few seconds.
	 2.	 To start a new document:
	 	 •	 Click on the + (Blank) 

button on the main screen.
	 3.	 To change the font:
	 	 •	 Highlight the text.
	 	 •	 Click on the Font menu 

(e.g., Arial) and choose a 
new font.

	 4.	 Sharing a Document
	 	 •	 Sharing let others view or 

edit your document.
	 To share:
	 	 1.	 Click on the Share button 

in the top-right corner.
	 	 2.	 Enter your teacher's or 

friend's email address.
	 	 3.	 Click on Send.
	 	 Your friend will receive a link 

to view or edit the document.
Art Integration
	 Do yourself.

8. Introduction to the Internet

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (c)	 Playing Board Games
	 2.	 (a)	 Internet Service Provider
	 3.	 (a)	 Uniform Resource Locator
	 4.	 (b)	 Browsing the Internet
	 5.	 (a)	 By typing its URL in the 

address bar.
B.	 Fill in the blanks:
	 1.	 computer or device
	 2.	 web browser
	 3.	 URL
	 4.	 search
	 5.	 HTTPS
C.	 True or False:
	 1.	 True	 2. False
	 3.	 True	 4. True
	 5.	 False
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D.	 Match the columns:
	 1. (d), 2. (c), 3. (a), 4. (b), 5.  (e).
E.	 Very Short Answer Type 

Questions:
	 1.	 A modem connects your device 

to the Internet via an ISP.
	 2.	 A search engine is a tool to find 

information on the internet 
using keywords.

	 3.	 By typing it in the browser's 
address bar.

	 4.	 Google
	 5.	 Hypertext Transfer Protocol.
F.	 Short Answer Type Questions:
	 1.	 To access a website:
	 	 1.	 Open Your Web Browser: 

Double-click the browser 
icon on your desktop or 
taskbar.

	 	 2.	 Enter the URL: Type the 
website's address into the 
address bar at the top of 
the browser.

	 	 3.	 Press Enter: Hit the "Enter" 
key on your keyboard to 
navigate to the website.

	 2.	 To connect to the Internet, 
you need a few essential 
components:

	 	 1	 Computer or Device: This 
can be a desktop, laptop, 
tablet, or smartphone.

	 	 2.	 Modem: A modem connects 
your device to the Internet 
through an Internet Service 
Provider (IPS).

	 	 3.	 Router: If you want to 
connect multiple devices 
wirelesly, you need a 
router. Some modems have 
built-in routers.

	 	 4.	 ISP Subscription: 
An Internet Service 
Provider (ISP) supplies 
the connection to the 
Internet. This could be 
through various types of 
connections like DSL, cable, 
fiber-optic, or satellite.

	 	 5.	 Web Browser: Software like 
Google Chrome, Mozilla 
Firefox, or Microsoft Edge 
is used to access websites.

	 3.	 URL (Uniform Resource 
Locator) :

	 	 The web address of a specific 
page or resource on the Internet 
(e.g., www.example.com).

	 4.	 Open a search engine, type 
related keywords in the search 
box, and press Enter.

	 5.	 Uses of the Internet
	 	 The Internet is a powerful tool 

with numerous applications. 
Here are some common uses:

	 	 1.	 Communication: Email, 
instant messaging, and 
video calls help people 
stay connected across long 
distances.

	 	 2.	 Information retrieval: 
You can access a wealth 
of information on almost 
any topic, from news to 
scientific research.

	 	 3.	 Entertainment: Streaming 
services, online games, 
and social media provide 
a variety of entertainment 
options.

	 	 4.	 Education: Online courses, 
tutorials, and educational 
resources make learning 
accessible from anywhere.
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	 	 5.	 Shopping: E-commerce 

websites allow you to 
buy and sell products and 
services online.

Art Integration
	 Do yourself.

9. Programming Concepts  
with Scratch

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (d)	 all of these
	 2.	 (b)	 Constumes tab
	 3.	 (a)	 Costumes tab
	 4.	 (c)	 middle
	 5.	 (b)	 right
B.	 Fill in the blanks:
	 1.	 programming
	 2.	 visual
	 3.	 Costumes
	 4.	 sounds
	 5.	 backdrop

C.	 Tick () the correct statements and 
cross () the wrong ones:

	 1.  2.  3.  4.  5. 

D.	 Match the columns:
	 1. (d), 2. (e), 3. (b), 4. (c), 5.  (a).
E.	 Very Short Answer Type 

Questions:
	 1.	 Programming is a set of 

instructions given to the 
computer for performing any 
task.

	 2.	 Costume panel shows various 
poses, stances, or expressions 
of the current sprite.

	 3.	 Sprite is a character used in a 
Scratch project, like a cat, ball, 
apple, etc.

	 4.	 Sound panel is used to add, 
record, and edit sounds in 
Scratch.

F.	 Short Answer Type Questions:
	 1.	 Launching Scratch
	 	 1.	 To launch Scratch 

application, click on Start.
	 	 2.	 Click on Scratch.
	 2.	 File menu includes options 

to create new Scratch project 
to load an existing project 
and to save the project on the 
computer.

	 3.	 Code Panel:
	 	 This appears when you click 

on Code tab on left hand side. 
It shows different blocks under 
various categories like Motion, 
Events, Looks, Variables, 
Control, etc. Each block is like 
an instruction to the computer 
to do a task. You can click on 
Add Extension button that 
exists at the bottom to add 
more categories of blocks like 
Pen and Music. Pen blocks 
help in drawing figures on the 
stage and Music blocks help in 
playing different instruments.

	 4.	 Event Handling
	 	 As event is any action that 

occurs at any point of time 
before, after or during 
animation. For example, user 
clicks on stage, or a key is 
pressed on the keyboard etc. 
In Scratch, we can decide what 
to do when an event occurs 
For example, if user clicks 
anywhere on the stage or on 
a sprite, it lets the sprite do 
something. The main approach 
towards event handling is to 
identify the exact event block 



Answer Key26
and a logical sequence of 
actions to be done. Let's do an 
exercise : Arrow keys to move a 
Beachball sprite.

	 	 Explanation : The movement 
direction for the Beachball is 
set by using point in direction 
block from Motion category 
for each of the 4 arrow keys as 
mentioned below:

	 	 •	 0 – upward

	 	 •	 180 – downward

	 	 •	 90 – towards right side

	 	 •	 –90–towards left side 
(reverse of 90)

	 5.	 Changing Sprite's Costume
	 	 Add an apple from Sprites 

library.

	 	 Click on Costumes tab to open 
Costume editor.

	 	 Set Fill Colour, Outline Colour 
and use the editing toolbar to 
make changes inthe look of 
Apple sprite.

Art Integration
	 Do yourself.

Worksheet-1

A.	 Click the correct option:

	 1.	 (b)	 Play audio and video files

	 2.	 (c)	 Colors in Personalization

	 3.	 (a)	 Cut and Paste

	 4.	 (c)	 Ctrl + C

B.	 Fill the appropriate terms:

	 1.	 AutoPlay

	 2.	 Slide show

	 3.	 double-click

	 4.	 Redo

C.	 True / False :
	 1.	 True	 2. True
	 3.	 False	 4. True
D.	 Match the following :
	 1. (b),  2. (a), 3. (d), 4. (c).
E.	 Answer the following questions:
	 1.	 Groove Music
	 2.	 You can find the option to 

change the screen saver in 
settings > personalization > 
Lock Scren > Screen Saver 
settings.

	 3.	 •	 Click the start button on the 
task bar.

	 	 •	 Scroll down and select the 
settings app.

	 4.	 Review tab
F.	 Short Answer Type Questions:
	 1.	 To select multiple files at once 

in File Explorer :
	 	 Hold down the Ctrl key and 

click on each file you want to 
select. Alternatively, click and 
drag to draw a selection box 
around multiple files.

	 2.	 To customize the window color 
in windows 10 :

	 	 •	 Click on the start menu and 
select settings.

	 	 •	 Click on personalization.
	 	 •	 In the left hand menu, 

select colors.
	 	 •	 Select a color from the 

palette or choose custom 
color for more options.

	 	 •	 Toggle the switch for Title 
bars and window borders 
to apply the color to these 
elements.

	 3.	 In education, Multimedia helps 
in creating interactive learning 
environments. Educational 
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Software and videos make 
complex subjects easier to 
understand.

	 	 In entertainment, Multimedia 
content like movies, music and 
games provides relaxation and 
enjoyment.

	 4.	 Changing the font size helps 
make your text more readable 
or eye-catching.

	 	 Steps:
	 	 1.	 Select the Text: Highlight 

the text you want to resize.
	 	 2.	 Open Font Size Options: Go 

to the Home tab and use 
the Font Size drop-down 
menu.

	 	 3.	 Choose a Size: Select a 
size from the list or type a 
specific number.

Worksheet-2

A.	 Click the correct option:

	 1.	 (c)	 Align Left
	 2.	 (b)	 Insert tab
	 3.	 (a)	 Internet Service Provider
	 4.	 (b)	 Costumes tab
B.	 Fill the appropriate terms:
	 1.	 Layout	 2. WordArt
	 3.	 URL	 4. Backdrop
C.	 True / False :
	 1.	 False	 2. True
	 3.	 True	 4. True
D.	 Match thefollowing columns :
	 1. (c), 2. (e), 3. (d), 4. (a), 5. (b).
E.	 Answer the following questions:
	 1.	 In the Home tab
	 2.	 Go to the Picture Format tab 

and click the crop button

	 3.	 Google Docs is a free online 
word processor to write, edit, 
and share documents.

	 4.	 Hypertext Transfer Protocol.
F.	 Short Answer Type Questions:
	 1.	 Uses of the Internet
	 	 The Internet is a powerful tool 

with numerous applications. 
Here are some common uses:

	 	 1.	 Communication: Email, 
instant messaging, and 
video calls help people 
stay connected across long 
distances.

	 	 2.	 Information retrieval: 
You can access a wealth 
of information on almost 
any topic, from news to 
scientific research.

	 	 3.	 Entertainment: Streaming 
services, online games, 
and social media provide 
a variety of entertainment 
options.

	 	 4.	 Education: Online courses, 
tutorials, and educational 
resources make learning 
accessible from anywhere.

	 	 5.	 Shopping: E-commerce 
websites allow you to 
buy and sell products and 
services online.

	 2.	 File menu includes options 
to create new Scratch project 
to load an existing project 
and to save the project on the 
computer.

	 3.	 Two advantages of using 
Google Docs are:

	 	 •	 It is free and works on any 
device.

	 	 •	 It automatically saves your 
work every few seconds.



Answer Key28
	 4.	 Adjusting the size of a picture 

ensures it fits well with your 
document layout.

	 	 1.	 Select the Picture: Click on 
the picture you want to 
resize.

	 	 2.	 Resize Handles: Drag the 
corner handles to maintain 

the picture's aspect ratio, 
or drag the side handles to 
resize without maintaining 
the ratio.

	 	 3.	 Use the Format Tab: For 
precise resizing, go to the 
"Picture Format" tab and 
enter exact dimensions in 
the "Size" group.

oo
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1. Computer– A Machine

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (a)	 Abacus
	 2.	 (b)	 Analytical Engine
	 3.	 (a)	 Lady Ada Lovelace
	 4.	 (c)	 Integrated circuits
	 5.	 (c)	 Supercomputer
B.	 Fill in the blanks:
	 1.	 Abacus
	 2.	 Diffrence, Analytical
	 3.	 transistors
	 4.	 computer programmer
	 5.	 Neumann
C.	 True or False:
	 1.	 True	 2. False
	 3.	 True	 4. False
	 5.	 True
D.	 Answer the following questions:
	 1.	 Main differences between first 

and second generations of 
computers:

	 	 •	 The first generation used 
vacuum tubes, were large 
and consumed a lot of 
power.

	 	 •	 The second generation 
used transistors, making 
computers smaller, faster, 
and more reliable.

	 2.	 First widely popular personal 
computer and its release year:

	 	 •	 The IBM PC was one of the 
first widely popular personal 
computers, released in 1981.

	 3.	 How smartphones changed 
communication:

	 	 •	 Smartphones have enabled 
instant messaging, video 
calling, and social media 
acess, allowing people to 
stay connected in real-time 
rgardless of location.

Art Integration
	 Do yourself.

2. Page Layout and Hyperlinks  
in MS Word

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (c)	 Layout
	 2.	 (b)	 Insert
	 3.	 (b)	 Portrait
	 4.	 (b)	 Insert > Blank Page
	 5.	 (c)	 Layout tab
B.	 Fill in the blanks:
	 1.	 Layout
	 2.	 Insert
	 3.	 A4
	 4.	 Insert
	 5.	 Headers, footers
C.	 True or False:
	 1.	 False	 2. True
	 3.	 True	 4. False
	 5.	 True
D.	 Answer the following questions:
	 1.	 To set custom margins:
	 	 1.	 Go to the "Layout" tab.
	 	 2.	 Click on "Margins" in the 

Page Setup group.
	 	 3.	 Select "Custom Margins" 

at the bottom of the 
dropdown menu.
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	 	 4.	 In the Page Setup dialog 

box, adjust the margins as 
needed.

	 2.	 To insert a blank page into your 
document:

	 	 1.	 Place the cursor where you 
want the new page.

	 	 2.	 Go to the "Insert" tab.
	 	 3.	 Click on "Hyperlink" in the 

Links group.
	 3.	 To create ehyperlinks to a 

website:
	 	 1.	 Highlight the text or select 

the object you want to 
hyperlink.

	 	 2.	 Go to the "Insert" tab.
	 	 3.	 Click on "Hyperlink" in the 

Links group.
	 	 4.	 In the Insert Hyperlink 

dialog box, enter the URL 
for a website or nagivate 
to the file location for a 
document.

	 4.	 To insert page numbers:
	 	 1.	 Go to the "Insert" tab.
	 	 2.	 Click on "Page Number" 

in the Header & Footer 
group.

	 	 3.	 Choose the location and 
style of the page number.

	 5.	 Headers appear at the top and 
footers at the bottom of each 
page; they are used to display 
information like page numbers, 
document title, or author's 
name.

Art Integration
	 Do yourself.

3. MS Word : Working with Tables

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (c)	 Drawing a table
	 2.	 (d)	 Both b and c
	 3.	 (a)	 Select the cells, right-click, 

and choose Merge Cells
	 4.	 (c)	 Layout (under Table Tools)
	 5.	 (a)	 Select the column, right-

click, and choose Delete 
Cells

B.	 Fill in the blanks:
	 1.	 Draw Table
	 2.	 Tab
	 3.	 Design
	 4.	 Insert
	 5.	 Shading
C.	 True or False:
	 1.	 False	 2. True
	 3.	 False	 4. True
	 5.	 False
D.	 Answer the following questions:
	 1.	 •	 Plae the cursor where you 

want to insert the table.
	 	 •	 Go to the Insert tab on the 

Ribbon.
	 	 •	 Click on the Table button 

inthe Tables group.
	 	 •	 Select Insert Table from the 

dropdown menu.
	 	 •	 In the Insert Table dialog 

box, enter the number of 
columns and rows you 
want.

	 	 •	 Click OK to insert the table.
	 2.	 •	 Select a column by clicking 

above it.
	 	 •	 Right-click and choose 

Insert.
	 	 •	 Select Insert Columns to 
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the Right.

	 3.	 •	 Select the cells you want to 
merge.

	 	 •	 Right-click and choose 
Merge Cells.

	 4.	 •	 Select the row or column 
you want to delete.

	 	 •	 Right-click and choose 
Delete Cells.

	 	 •	 Select Delete Entire Row or 
Delete Entire Column.

	 5.	 •	 Select the cell(s) where you 
want to change the text 
alignment.

	 	 •	 Go to the Layout tab under 
Table Tools.

	 	 •	 In the Alignent group, 
choose the desired 
alignment option (e.g., 
Top, Left, Center, Bottom 
Right).

Art Integration
	 Do yourself.

4. Introduction to Spreadsheets 
and MS Excel

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (d)	 Slide
	 2.	 (b)	 Ctrl + S
	 3.	 (a)	 Ctrl + A
	 4.	 (d)	Next to existing worksheet 

tabs
	 5.	 (b)	 Press F2
B.	 Fill in the blanks:
	 1.	 cell		 2. File
	 3.	 Ctrl + P	 4. work-book
	 5.	 Formula

C.	 True or False:
	 1.	 True	 2. False
	 3.	 False	 4. True
	 5.	 False
D.	 Answer the following questions:
	 1.	 •	 Click on the File tab.
	 	 •	 Select Open.
	 	 •	 Browse to the location of 

the workbook.
	 	 •	 Select the workbook and 

click Open.
	 2.	 •	 Click on the plus icon next 

to the existing worksheet 
tabs.

	 	 •	 A new worksheet will be 
added to the workbook.

	 3.	 •	 A cell range is a group of 
adjacent cells.

	 	 •	 Select a range: Click on the 
first cell, hold down the 
Shift key, and click on the 
last cell.

	 4.	 •	 Double-click the worksheet 
tab you want to rename.

	 	 •	 Type the new name and 
press Enter.

	 5.	 •	 Double-click the cell you 
want to edit.

	 	 •	 Make the necessary 
changes.

	 	 •	 Press Enter to save the 
changes.

Art Integration
	 Do yourself.

5. Introduction to Spreadsheets 
and MS Excel

Skill Sharpeners
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A.	 Click () the correct option:
	 1.	 (b)	 Organizing and analyzing 

data
	 2.	 (a)	 A box where rows and 

columns meet
	 3.	 (b)	 = SUM 0
	 4.	 (a)	 A Google account
	 5.	 (b)	 Top right corner
B.	 Fill in the blanks:
	 1.	 spreadsheet	 2. letters
	 3.	 AVERAGE ( )	 4. cell
	 5.	 text color
C.	 True or False:
	 1.	 False	 2. True
	 3.	 False	 4. True
	 5.	 False
D.	 Answer the following questions:
	 1.	 •	 Google Sheets is an online 

spreadsheet tool that 
allows you to create, edit, 
and share spreadsheets 
from any device conneted 
to the internet.

	 2.	 •	 Bold Text: Select a cell, then 
click the B icon.

	 	 •	 Change Text Color: Click 
the text color icon and 
choose a color.

	 3.	 •	 The small box where rows 
and columns meet. Each 
cell has an address (like A1, 
B2).

	 4.	 •	 SUM: =SUM(B2:B4)
	 	 •	 AVERAGE: =AVERAGE 

(B2:B4)
	 	 •	 COUNT: =COUNT (A2:A4)
	 5.	 •	 Click the "Share" bottom in 

the top right corner.
	 	 •	 Enter the email address 

of the person you want to 

share with.
	 	 •	 Choose their access level 

(Viewer, Commenter, Editor).
	 	 •	 Click "Send."
Art Integration
	 Do yourself.

6. Graphics in MS PowerPoint

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (a)	 Title Slide
	 2.	 (b)	 Insert
	 3.	 (b)	 Insert > Picture > This 

Device
	 4.	 (a)	 SmartArt
	 5.	 (d)	 Grid Layout

B.	 Fill in the blanks:
	 1.	 Title and Content
	 2.	 Insert	 3. Title Bar
	 4.	 SmartArt	 5. Insert

C.	 True or False:
	 1.	 False	 2. True
	 3.	 True	 4. True
	 5.	 False

D.	 Answer the following questions:
	 1.	 •	 Used for the introduction, 

includes placeholders for 
the presentation title and 
subtitle.

	 2.	 •	 Click on the content 
placeholder or go to the 
"Insert" tab.

	 	 •	 Click on "Table".
	 	 •	 Select the number of rows 

and columns.
	 	 •	 Enter your data into the 

table cells.
	 3.	 •	 Click on the content 

placeholder or go to the 
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"Insert" tab.

	 	 •	 Click on "SmartArt".
	 	 •	 Choose a SmartArt graphic 

from the gallery and click 
"OK".

	 	 •	 Enter your text into the 
SmartArt graphic.

	 4.	 •	 Click on the content 
placeholder or go to the 
"Insert" tab.

	 	 •	 Click on "Pictures".
	 	 •	 Choose "This Device" to 

upload an image from 
your computer.

	 	 •	 Select the picture and click 
"Insert".

	 5.	 To insert audio:
	 	 •	 Go to the "Insert" tab.
	 	 •	 Click on "Audio".
	 	 •	 Choose "This Device" to 

upload an audio fire from 
your computer.

	 	 •	 Select the audio file and 
click "Insert".

	 	 To insert video:
	 	 •	 Click on the content 

placeholder to go to the 
"Insert" tab.

	 	 •	 Click on "Video".
	 	 •	 Choose "This Device" to 

upload a video from your 
computer or select from 
online sources.

	 	 •	 Select the video and click 
"Insert".

Art Integration
	 Do yourself.

7. MS PowerPoint–Animations 
and Transitions

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (c)	 Animations
	 2.	 (d)	 Click onPreview
	 3.	 (c)	 Transitions tab
	 4.	 (b)	 Apply to All
	 5.	 (b)	 Slide Sorter view
B.	 Fill in the blanks:
	 1.	 Animations	 2. Effect
	 3.	 Animation	 4. Apply
	 5.	 Slide Sorter
C.	 True or False:
	 1.	 False	 2. True
	 3.	 False	 4. True
	 5.	 True
D.	 Answer the following questions:
	 1.	 •	 Animations bring elements 

on your slides to life, while 
transitions add smooth 
effects when moving from 
one slide to the next.

	 2.	 •	 Select the slide title text 
box.

	 	 •	 Go to the Animations tab.
	 	 •	 Click on Add Animation 

and choose Fly In.
	 	 •	 Click Preview to see the 

title fly in.
	 3.	 •	 Animations tab.
	 4.	 •	 Select any slide.
	 	 •	 Go to the Transitions tab.
	 	 •	 Choose a transition.
	 	 •	 Click on Apply to All.
	 5.	 To insert audio:
	 	 •	 Slide Sorter view allows 

you to see and organize all 
your slides at once.

Art Integration
	 Do yourself.
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8. Introduction to Google Slides

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 Creating presentations
	 2.	 (c)	 Animation
	 3.	 (c)	 Speaker Notes Section
	 4.	 (a)	 A Google account
	 5.	 (b)	 Click on the "+" button
B.	 Fill in the blanks:
	 1.	 presentations	 2. Cell
	 3.	 Present	 4. Animation
	 5.	 design
C.	 True or False:
	 1.	 True	 2. False
	 3.	 True	 4. False
	 5.	 False
D.	 Answer the following questions:
	 1.	 Google Slides is an online 

presentation tool that allows 
you to create, edit, and share 
slide decks from any device 
connected to the internet.

	 2.	 Select an object, click "Insert" > 
"Animation," and choose how 
it appears, exits, or moves.

	 3.	 •	 Bold
	 	 •	 Italic
	 	 •	 Change font and size
	 4.	 •	 Click the "Share" button in 

the top right corner.
	 	 •	 Enter the email addresses 

of people you want to share 
with.

	 	 •	 Set their access level 

(Viewer, Commenter, 
Editor).

	 5.	 Add notes to help you during 
your presentation.

Art Integration
	 Do yourself.

9. Internet Browsing and 
Searching

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 To browse and view 

websites
	 2.	 (b)	 Gmail
	 3.	 (c)	 Google
	 4.	 (c)	 Have face-to-face meetings 

over the internet
	 5.	 (b)	 YouTubes
B.	 Fill in the blanks:
	 1.	 interconnected computers
	 2.	 Microsoft Edge
	 3.	 Amazon
	 4.	 definitions
	 5.	 Google Maps
C.	 True or False:
	 1.	 False	 2. True
	 3.	 False	 4. True
	 5.	 False
D.	 Answer the following questions:
	 1.	 The internet is a global network 

of interconnected computers 
that allows people to share 
information and communicate 
with each other.

	 2.	 Gmail and Yahoo Mail.
	 3.	 The primary function of a web 
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browser is to access and view 
websites on the internet.

	 4.	 You can search for videos on 
platforms like YouTube or 
Vimeo by entering your search 
query in the search bar.

	 5.	 Online dictionaries provide 
definitions, pronunciations, 
and translations of words.

Art Integration
	 Do yourself.

10. More About Scratch
Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (a)	 Hide
	 2.	 (b)	 Say
	 3.	 (c)	 Change
	 4.	 (a)	 Camera
B.	 Fill in the blanks:
	 1.	 looks
	 2.	 choose a sound
	 3.	 Go
	 4.	 Hide
	 5.	 John won Neumannss
C.	 True or False:
	 1.	 True	 2. False
	 3.	 True	 4. True
D.	 Answer the following questions:
	 1.	 The purple-coloured blocks 

indicate Looks block menu. 
These blocks are applied to 
change the appearance of a 
Sprite, such as colour, look, 
size, etc.

	 2.	 •	 Click on Paint button, the 
click on Costumes tab.

	 	 •	 Draw and colour a new 
Sprite.

	 	 •	 Click on onvert to Bitmap 
for a smooth vector image.

	 	 •	 Name the Sprite by typing 
inthe Sprite text box an 
press Enter.

	 	 •	 Modify size, position, and 
direction if needed.

	 3.	 •	 Take the mouse on Choose 
a Backdrop button.

	 	 •	 Click on Choose a 
Backdrop, Paint, Surprise, 
or Upload Backdrop 
options.

	 	 •	 Select or draw the new 
backdrop.

	 	 •	 The new backdrop appears 
behind the Sprite.

	 4.	 •	 Click on Sounds tab.
	 	 •	 Click on Choose a Sound 

button and select a sound.
	 	 •	 Use Sound blocks like Pay 

Sound in the Script area.
	 	 •	 Click on Go button to pay 

the script with sound.
Art Integration
	 Do yourself.

Worksheet-1

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (a)	 Lady Ada Lovelace
	 2.	 (b)	 Insert
	 3.	 (c)	 Drawing a table
	 4.	 (d)	 Slide
B.	 Fill in the blanks:
	 1.	 computer programmer
	 2.	 A4
	 3.	 Insert
	 4.	 cell
C.	 True or False:
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	 1.	 False	 2. False
	 3.	 False	 4. True
D.	 Answer the following questions:
	 1.	 The IBM PC was one of the 

first widely popular personal 
computers, released in 1981.

	 2.	 To insert page number:
	 	 •	 Go to the Insert tab.
	 	 •	 Click on Page Number in 

the Header & Footer group.
	 	 •	 Choose the location and 

style of the page number.
	 3.	 •	 Select the cells you want to 

merge.
	 	 •	 Right Click and choose 

Merge Cells.
	 4.	 •	 Click on the File tab.
	 	 •	 Select open.
	 	 •	 Browse to the location of 

the workbook.
	 	 •	 Select the workbook and 

click open.

Worksheet-2

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (a)	 Title Slide
	 2.	 (c)	 Animations
	 3.	 (b)	 To browse and view 

websites

	 4.	 (a)	 Hides
B.	 Fill in the blanks:
	 1.	 Insert
	 2.	 Effect
	 3.	 Microsoft Edge
	 4.	 Choose a Sound
C.	 True or False:
	 1.	 True	 2. False
	 3.	 False	 4. True
D.	 Answer the following questions:
	 1.	 •	 Click on the content 

placeholder or go to the 
"Insert" tab.

	 	 •	 Click on "SmartArt".
	 	 •	 Choose a SmartArt graphic 

from the gallery and click 
"OK".

	 	 •	 Enter your text into the 
SmartArt graphic.

	 2.	 Animations tab.
	 3.	 Internet is a global network 

of interconnected computers 
that allows people to share 
information and communicate.

	 4.	 The purple-coloured blocks 
in Scratch that change the 
appearance of a sprite, like its 
colour, size, and look.

oo
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1. Mastering Mail Merge in  

MS Word 2021

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 Personalizing mass 

documents
	 2.	 (c)	 Mailings tab
	 3.	 (b)	 Excel spreadsheet
	 4.	 (c)	 Preview Results button
	 5.	 (c)	 Finishing & merging
B.	 Fill in the blanks:
	 1.	 personalized
	 2.	 Mailings
	 3.	 placeholder
	 4.	 Preview
	 5.	 Envelops
C.	 True or False:
	 1.	 False	 2. True
	 3.	 False	 4. True
	 5.	 True
D.	 Questions and Answers:
	 1.	 Mail Merge in MS Word 2021 

is a valuable tool that simplifies 
the process of creating 
personalized documents for 
multiple recipients.

	 2.	 To begin a Mail Merge, you 
need to connect your main 
document to a data source. 
The data source provides the 
specific information that will 
be inserted into the merge 
fields within your document.

	 3.	 Merge fields are crucial to the 
Mail Merge process as they 
define where personalized data 
will appear in the document. 

Tese fields pull information 
from your data source and 
insert it into the document 
where the merge field is placed.

	 4.	 Before finalizing your Mail 
Merge, it's important to 
preview the merged documents 
to ensure that everything looks 
correct. This step allows you 
to verify that the right data is 
appearing in the correct places.

	 5.	 Edit Individual Documents: 
Create a new document 
containing all the merged 
letters, which you can review 
and edit further if needed.

	 	 Print Documents: Send the 
merged documents directly to 
the printer.

	 	 Send Email Messages: Send 
the merged documents as 
emails if your document is set 
up for e-mail merge.

E. Assertion-Reason Based Questions:
	 1.	 (c)	 	Assertion is true, but 

Reason is false.
	 2.	 (c)	 Assertion is true, but 

Reason is false.
F.	 Source-Based Questions:
	 •	 Open the main document 

(letter template) in MS Word.
	 •	 Go to the "Mailings" tab.
	 	 Click "Select Recipients" and 

choose "Use an Existing List."
	 •	 Browse and select the Excel 

spreadsheet.
	 •	 Insert merge fields like (First 

Name), (Last Name), (Address) 
into the letter where needed.
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	 	 •	 Click "Preview Results" to 

check.
	 	 •	 Click "Finish & Merge" and 

choose "Print Documents" 
to generate personalized 
letters for all recipients.

Art and Integration
	 Do yourself.

2. MS Word 2021: Using 
Functions and Formulas

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 Number
	 2.	 (b)	 MAX
	 3.	 (a)	 Start of a formula
	 4.	 (c)	 *
	 5.	 (b)	 TRUE
B.	 Fill in the blanks:
	 1.	 fill
	 2.	 add
	 3.	 =(Equal to)
	 4.	 true
	 5.	 Alignment
C.	 True or False:
	 1.	 False	 2. True
	 3.	 True	 4. False
	 5.	 True
D.	 Questions and Answers:
	 1.	 The Format Cells dialog box 

provides various options for 
customizing the appearance of 
your cells, including number 
formatting, alignment, font, 
border, fill, and protection.

	 2.	 The Alignment tab allows 
you to control the positioning 
and orientation of text within 
a cell, including options like 
horizontal (Left, Center, Right) 

and vertical (Top, Middle, 
Bottom) alignment.

	 3.	 SUM adds all the numbers 
in a specified range, while 
AVERAGE calculates the mean 
(average) of the numbers in the 
specified range.

	 4.	 Arithmetic operators allow 
basic calculations:

	 	 •	 + (Addition),  
– (Subtration),  
* (Multiplication),  
/ (Division),  
^ (Exponentiation).

	 5.	 The IF function performs a 
logical text and returns one 
value if the condition is TRUE 
and another value if the 
condition is FALSE.

E.	 Source-Based Questions:
	 1.	 •	 John should use the SUM 

function to calculate the 
total sales (from: "Sum: 
=SUM (A1:A5) odds all 
values in the range A1 to 
A5.")

	 	 •	 John should use the 
AVERAGE function to 
calculate the average sales 
(rom: "Average: AVERAGE 
(A1:A5) calculates the 
average of values inthe 
range A1 to A5.")

	 2.	 •	 John can highlight the 
top-selling product by 
using Excel's Fill tab 
options (From: "The Fill 
tab provides options for 
additng background colors 
or patterns to your cells.")

Art and Integration
	 Do yourself.
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3. Visualize Your Data : 
Presentation with Charts  

in MS Excel 2021
Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (c)	 Line Chart
	 2.	 (c)	 Legend
	 3.	 (b)	 Insert
	 4.	 (c)	 Pie Chart
	 5.	 (c)	 By using the Chart Tools 

Design tab
B.	 Fill in the blanks:
	 1.	 Column
	 2.	 Bar
	 3.	 Data Lebels
	 4.	 Format Axis
	 5.	 Goal
C.	 True or False:
	 1.	 False	 2. True
	 3.	 False	 4. True
	 5.	 False
D.	 Questions and Answers:
	 1.	 Line charts connect data points 

with a line, ideal for showing 
trends over time or continuous 
data.

	 2.	 •	 Select the Chart: Click on 
the Chart. Ensure the chart 
is selected.

	 	 •	 Go to Chart Tools Design: 
Click on the Chart Tools 
Design tab.

	 	 •	 Click Change Chart Type: 
Select Change Chart Type 
from the dropdown menu.

	 	 •	 Choose New Type: Select 
a different chart type from 
the options available.

	 		  Example: Change a 
Column Chart to a Line 
Chart to represent trends.

	 3.	 •	 Access Formatting Options:  
Click on the Chart: Select 
the chart you want to 
format.

	 	 •	 Format Chart Elements:
	 	 	 □	 Chart Title: Click on 

the title to edit it.
	 	 	 □	 Axes: Right-click on 

the axis and select 
Format Axis to adjust 
settings.

	 	 	 □	 Data Lebels: Click 
on the data labels to 
format them.

	 4.	 Legend: Identifies different 
data series in the chart with 
corresponding colors or 
patterns.

	 5.	 •	 Set Up Your Data: Ensure 
you have a formula where 
you want to apply Goal 
Seek.

	 	 •	 Use Goal Seek:
	 	 	 □	 Go to Data Tab: Click 

on the Data tab.
	 	 	 □	 Click What: If 

Analysis: Select What-
If Analysis from the 
dropdown menu.

	 	 	 □	 Choose Goal Seek: 
Click on Goal Seek.

	 	 •	 Set Parameters:
	 	 	 □	 Set Cell: Specify the 

cell containing the 
formula.

	 	 	 □	 To Value: Enter the 
desired result.

	 	 	 □	 By Changing Cell: 
Select the cell to adjust.

	 			   Example: Determine 
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the required sales 
figure to achieve a 
target profit.

E. Assertion-Reason Based Questions:
	 1.	 (c)	 Assertion is true, but 

Reason is false.
	 	 	 Because pie charts are best 

for showing proportions, 
not comparisons.

Art and Integration
	 •	 Create a column chart forthe 

number of fruits sold (e.g., 
apples, bananas, grapes, 
oranges).

	 •	 Use the Fill option to apply 
different bright colors to each 
fruit category.

	 •	 Add a Chart Title "Fruits Sold 
in Week."

	 •	 Use a Border around the chart 
for better visual separation.

	 •	 Insert a small fruit-related 
picture (like an apple or 
banana) inside the chart using 
Insert Shapes > Picture to 
enhance the presentation.

	 •	 Customize the font style of the 
chart labels to make it more 
playful and colorful.

4. PowerPoint 2021: Advanced 
Technique for Stunning 

Presentations

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 Home
	 2.	 (c)	 Slide Show tab
	 3.	 (b)	 Apply to All
	 4.	 (d)	 All of the above
	 5.	 (a)	 Ctrl
B.	 Fill in the blanks:

	 1.	 Home	 2. Slide
	 3.	 drag	 4. slide show
	 5.	 Presenter
C.	 True or False:
	 1.	 False	 2. False
	 3.	 True	 4. False
	 5.	 False
D.	 Questions and Answers:
	 1.	 When you start a new 

presentation, you might need 
more than one slide.

	 2.	 •	 Click on the "Transitions" 
tab.

	 	 •	 Choose a transition effect 
from the gallery.

	 	 •	 Click "Apply To All" if you 
want the same transition 
for all slides.

	 3.	 Entrance, Emphasis, Exit, and 
Motion Paths.

	 4.	 •	 Go to the "Insert" tab.
	 	 •	 Click on "Video" and 

choose from "Video on My PC" 
or "Online Video."

	 5.	 Presenter View lets you see 
your notes and upcoming 
slides on one screen, while 
your audience sees only the 
current slide.

E. Assertion-Reason Based Questions:
	 (a)	 Both Assertion and Reason 

are true, and Reason is correct 
explanation of Assertion.

F.	 Source-Based Questions:
	 •	 Select the object or text you 

want to animate.
	 •	 Click on the "Animations" tab.
	 •	 Choose the "Fade" animation 

from the gallery.
Art and Integration
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	 •	 Create a presentation with 3-4 

slides.
	 •	 Apply a transition effect like 

"Wipe" to all slides from the 
"Transitions" tab.

	 •	 Apply an animation like "Fly 
In" to text or images from the 
"Animations" tab.

	 •	 Select a theme from the 
"Design" tab (for example, "Ion" 
for a modern, techy look if your 
topic is about technology).

	 •	 The theme is suitable because 
it provides a professional and 
cohesive appearance matching 
the topic of the presentation.

5. Internet

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 Google
	 2.	 (c)	 Sending and receiving 

electronic mesages
	 3.	 (b)	 Zoom
	 4.	 (c)	 Twitter
	 5.	 (b)	 Cyberbullying
B.	 Fill in the blanks:
	 1.	 Google
	 2.	 electronic
	 3.	 Online chatting
	 4.	 Skype
	 5.	 share, interact
C.	 True or False:
	 1.	 False	 2. False
	 3.	 True	 4. False
	 5.	 False
D.	 Questions and Answers:
	 1.	 •	 Speed: Emails are delivered 

almost instantly, allowing 
for quick communication 

across the globe.
	 	 •	 Convenience: Emails can 

be sent and received from 
any device connected to 
the internet.

	 	 •	 Cost-effective: Sending an 
email is free.

	 	 •	 Documentation: Emails 
provide a written record of 
communication.

	 	 •	 Bulk Communication: 
Allows for sending 
messages to multiple 
recipients simultaneously.

	 2.	 A search engine is a powerful 
tool that helps users to find 
specific information on 
the internet. It operates by 
indexing web pages and using 
algorithms to retrieve the most 
relevant results based on the 
keywords entered by the user.

	 3.	 •	 Cost-effective: Reduces 
travel expenses.

	 	 •	 Time-saving: Saves time 
by eliminating travel.

	 	 •	 Collaboration: Facilitates 
collaboration among 
remote teams.

	 	 •	 Accessibility: Meetings 
can be recorded for future 
reference.

	 4.	 •	 Voice and Video Calls
	 	 •	 Instant Messaging
	 	 •	 Screen Sharing
	 	 •	 File Sharing
	 	 •	 Group Calls
	 5.	 Platforms like Linked in provide 

opportunities for professional 
networking, job searching, and 
career development.

E. Assertion-Reason Based Questions:
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	 1.	 (a)	 Both Assertion and Reason 

are true, and Reason is 
the correct explanation of 
Assertion.

	 2.	 (c)	 Assertion is true, but 
Reason is false.

F.	 Source-Based Questions:
	 1.	 Advantages:
	 	 •	 Ability to share information 

instantly.
	 	 •	 Connect with others across 

the globe.
	 	 Disadvantages:
	 	 •	 Privacy concerns.
	 	 •	 Spread of misinformation.
	 2.	 •	 Protect your personal 

information and adjust 
privacy settings.

	 	 •	 Verify information before 
sharing.

	 	 •	 Avoid engaging in harmful 
or disrespectful behavior 
online.

Art and Integration
	 Do yourself.

6. AI for all: A Beginner's Guide 
to Artificial Intelligence

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (c)	 Task Automation
	 2.	 (b)	 Physical Strength
	 3.	 (b)	 Processing Power
	 4.	 (c)	 Artificial Intelligence
	 5.	 (b)	 A chess-playing computer
B.	 Fill in the blanks:
	 1.	 Artificial Intelligence
	 2.	 intelligence
	 3.	 processing power
	 4.	 cognitive abilities

	 5.	 father
C.	 True or False:
	 1.	 False	 2. False
	 3.	 False	 4. True
	 5.	 True
D.	 Questions and Answers:
	 1.	 Artificial Intelligence (AI) is a 

branch of computer science that 
focuses on creating machines 
capable of performing tasks 
that typically require human 
intelligence. These tasks 
include reasoning, learning, 
problem-solving, perception, 
language understanding, and 
more.

	 2.	 Humans are considered 
intelligent due to their 
advanced cognitive abilities, 
which include complex 
thought processes, learning 
from experience, language and 
communication, emotional 
intelligence,and creativity and 
innovation.

	 3.	 The need for AI arises from 
the desire to enhance human 
capabilities, solve complex 
problems and improve 
efficiency across various 
domains. AI can process vast 
amounts of data quickly, 
peform repetitive tasks with 
accuracy, and provide insights 
beyond human capability.

	 4.	 Earlier Computers: Limited 
processing power, basic 
functionality, and no 
intelligence.

	 	 Modern Computers: 
Advanced processing power, 
multifunctional use, and ability 
to run AI algorithms, learn 
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from data, and perform tasks 
requiring cognitive abilities.

	 5.	 •	 Learning Ability
	 	 •	 Adaptability
	 	 •	 Problem-Solving
	 	 •	 Reasoning
	 	 •	 Creativity
	 	 •	 Self-Awareness
E. Assertion-Reason Based Questions:
	 1.	 •	 AI drives innovation in 

fields like healthcare.
	 	 •	 AI can help doctors consult 

remotely (telemedicine).
	 	 •	 AI enables personalized 

healthcare services.
	 	 •	 AI systems analyze data for 

diagnosis and treatment 
predictions.

	 		  (From: "Innovation: AI 
drives innovation in fields 
like healthcare... and 
from applications of video 
conferencing in healthcare.")

Art and Integration
	 Do yourself.

7. Programming with Scratch

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 Motion Block
	 2.	 (c)	 Starts drawing on the stage
	 3.	 (a)	 Wait Block
	 4.	 (c)	 Using the Variables Block
	 5.	 (a)	 Repeats actions indefinitely
B.	 Fill in the blanks:
	 1.	 motion
	 2.	 looks
	 3.	 pen
	 4.	 variable

	 5.	 wait
C.	 Questions and Answers:
	 1.	 Sprites are characters in Scratch 

that you can control and 
program using blocks. They 
are used to create animations, 
games,and interactive stories.

	 2.	 •	 Drag the "move 10 steps" 
block from the Motion 
category.

	 	 •	 Click the block to make the 
sprite move forward.

	 	 •	 You can change the number 
of steps by adjusting the 
value inside the block.

	 3.	 The "forever" block is used to 
continuously repeat the 
actions inside it until the 
project stops.

	 4.	 Variables Blocks are used 
to store and manage data 
like scores, timers, or other 
information in a project.

	 5.	 •	 Drag the "swtch backdrop 
to [backdrop name]" block 
from the Looks category.

	 	 •	 You can also use the "change 
[effect] by [number]" 
block to add visual effects 
like color or brightness 
changes.

8. Animation with TupiTube

Skill Sharpeners

A.	 Click () the correct option:
	 1.	 (b)	 Animation
	 2.	 (c)	 Properties Panel
	 3.	 (c)	 Rotation Tween
	 4.	 (a)	 File
	 5.	 (b)	 File > Export
B.	 Fill in the blanks:
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	 1.	 animations
	 2.	 Stage Area
	 3.	 Scene
	 4.	 coloring
	 5.	 Timeline
C.	 True or False:
	 1.	 False	 2. True
	 3.	 False	 4. False
	 5.	 True
D.	 Questions and Answers:
	 1.	 TupiTube is a user-friendly, 

open-source animation 
software designed for creating 
animations and interactive 
stories.

	 2.	 •	 Toolbar
	 	 •	 Timeline
	 	 •	 Stage Area
	 	 •	 Properties Panel
	 3.	 A scene is a distinct section or 

part of your animation that can 
contain different backgrounds, 
characters (sprites), and 
actions.

	 4.	 •	 Select the object.
	 	 •	 Go to Animation > Add 

Rotation Tween.
	 	 •	 Enter starting and ending 

rotation angles in the 
properties panel.

	 	 •	 Adjust timing using the 
timeline.

	 	 •	 Click Play to preview.
	 5.	 •	 Click on File.
	 	 •	 Select Export.
	 	 •	 Choose Export as Video.
	 	 •	 Select desired video 

settings and click Export.
E. Assertion-Reason Based Questions:

	 1.	 (a)	 Both Assertion and Reason 
are true, and Reason is 
the correct explanation of 
Assertion.

	 2.	 (d)	 Both Assertion and Reason 
are false.

F.	 Source-Based Questions:
	 1.	 TupiTube is a free and open-

source animation software 
that enables users to create 
animations and interactive 
stories through a simple, user-
friendly interface.

2.	 •	 Easy to use and beginner-
friendly interface.

	 •	 No need for complex 
programming knowledge.

	 •	 Supports creating 
animations and interactive 
stories.

	 •	 Free and open-source.

Worksheet-1
A.	 Click () the correct option:
	 1.	 (b)	 MAX
	 2.	 (c)	 Line Chart
	 3.	 (c)	 Finishing & tab
	 4.	 (c)	 Slide Show tab
	 5.	 (c)	 *
B.	 Questions and Answers:
	 1.	 •	 Set Up Your Data: Ensure 

you have a formula where 
you want to apply Goal 
Seek.

	 	 •	 Use Goal Seek:
	 	 	 □	 Go to Data Tab: Click 

on the Data tab.
	 	 	 □	 Click What: If 

Analysis: Select What-
If Analysis from the 
dropdown menu.

	 	 	 □	 Choose Goal Seek: 
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Click on Goal Seek.

	 	 •	 Set Parameters:
	 	 	 □	 Set Cell: Specify the 

cell containing the 
formula.

	 	 	 □	 To Value: Enter the 
desired result.

	 	 	 □	 By Changing Cell: 
Select the cell to adjust.

	 			   Example: Determine 
the required sales 
figure to achieve a 
target profit.

	 2.	 •	 Click on the "Transitions" 
tab.

	 	 •	 Choose a transition effect 
from the gallery.

	 	 •	 Click "Apply to All", if you 
want the same transition 
for all sides.

	 3.	 Edit Individual Documents: 
Create a new document 
containing all the merged 
letters, which you can review 
and edit further if needed.

	 	 Print Documents: Send the 
merged documents directly to 
the printer.

	 	 Send Email Messages: Send 
the merged documents as 
emails if your document is set 
up foremail merge.

	 4.	 •	 IF function perfoms a 
logical test and returns one 
value if the condition is 
TRUE and another value if 
the condition is FALSE.

	 5.	 SUM adds all numbers 
in a specific range, while  
AVERAGE calculates the mean 
(average) of the numbers in the 
specific range.

C.	 Fill in the blanks:
	 1.	 Mailings
	 2.	 Presenter
	 3.	 Data Labels
	 4.	 add
	 5.	 Envelops
D.	 True or False:
	 1.	 True	 2. False
	 3.	 False	 4. False
	 5.	 False

Worksheet-2
A.	 Click () the correct option:
	 1.	 (c)	 Twitter
	 2.	 (a)	 Repeats actions idenfinitely
	 3.	 (a)	 File
	 4.	 (b)	 Animation
	 5.	 (c)	 Artificial Intelligence

B.	 Questions and Answers:
	 1.	 Variables Blocks are used 

to store and manage data 
like scores, timers, or other 
information in a project.

	 2.	 Humans are considered 
intelligent due to their 
advanced cognitive abilities, 
which include complex 
thought processes, learning 
from experience, language and 
communication, emotional 
intelligence,and creativity and 
innovation.

	 3.	 •	 Voice and video calls
	 	 •	 Instant messaging
	 	 •	 File sharing
	 	 •	 Screen sharing
	 	 •	 Groups calls
	 4.	 •	 Speed: Emails are delivered 

almost instantly, allowing 
for quick communication 
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across the globe.

	 	 •	 Convenience: Emails can 
be sent and received from 
any device connected to 
the internet.

	 	 •	 Cost-effective: Sending an 
email is free.

	 	 •	 Documentation: Emails 
provide a written record of 
communication.

	 	 •	 Bulk Communication: 
Allows for sending 
messages to multiple 
recipients simultaneously.

	 5.	 A scene is a distinct section or 

part of your animation that can 
contain different backgrounds, 
characters (sprites), and 
actions.

C.	 Fill in the blanks:
	 1.	 variable
	 2.	 animations
	 3.	 cognitive abilities
	 4.	 share, interact
	 5.	 father
D.	 True or False:
	 1.	 True	 2. False
	 3.	 True	 4. False
	 5.	 False

oo
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1. Unlocking the Digital World: 

Computer Systems & Their 
Languages

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (b)	 CPU
	 2.	 (c)	 Keyboard
	 3.	 (c)	 Supercomputer
	 4.	 (b)	 System software
	 5.	 (d)	 SGL
B.	 Fill in the blanks:
	 1.	 CPU
	 2.	 First Generation
	 3.	 Mainframe
	 4.	 Linux
	 5.	 Output
C.	 True or False:
	 1.	 False	 2. True
	 3.	 True	 4. False
	 5.	 False
D.	 Match the Columns:
	 1. (e), 2. (d), 3. (c), 4. (b), 5. (a).
E.	 Questions and Answers:
	 1.	 The CPU is reponsible for 

processing instructions and 
performing calculations.

	 2.	 Keyboard and Mouse.
	 3.	 Supercomputers are used 

for specialized tasks such as 
scientific simulations, weather 
forecasting, and cryptography.

	 4.	 System software manages 
hardware and provides an 
interface between user and 
specific tasks (like Paint, 
Antivirus).

	 5.	 Languages based on solving 
problems using constraints 
and logic, used in artificial 
intelligence and expert systems.

F.	 Assertion-Reason Based Questions:
	 1.	 (a)	 Both Assertion and Reason 

are true, and Reason is 
the correct explanation of 
Assertion.

	 2.	 (a)	 Both Assertion and Reason 
are true, and Reason is 
the correct explanation of 
Assertion.

G.	 Source-Based Questions:
	 1.	 Software is a collection of 

programs stored in digital form 
to solve problems and operate 
a computer.

	 2.	 Software is stored in computer 
memory.

	 3.	 Software is classified into two 
types: System Software and 
Application Software.

Art and Integration
	 Do yourself.

2. Decoding the Binary Universe: 
Understanding the 0's and 1's

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (c)	 2
	 2.	 (a)	 1010
	 3.	 (a)	 0011
	 4.	 (d)	 10111
	 5.	 (b)	 Subtraction
B.	 True or False:
	 1.	 False	 2. True
	 3.	 False	 4. True
	 5.	 False
C.	 Match the Columns:
	 1. (a), 2. (c), 3. (b), 4. (d), 5. (e).
D.	 Fill in the blanks:
	 1.	 base-10 number
	 2.	 0, 1
	 3.	 division by 2
	 4.	 0, 1		 5. 1's
E.	 Questions and Answers:
	 1.	 1100
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	 2.	 •	 Divide the decimal number 

by 2.
	 	 •	 Record the quotient and the 

remainder.
	 	 •	 Repeat this process until 

the quotient becomes 0.
	 	 •	 Read remainders from 

bottom to top to get the 
binary number.

	 3.	 •	 1's complement is found by 
flipping all the bits (0s to 
1s,, 1s to 0s).

	 	 •	 2's complement is found by 
taking the 1's complement 
and adding 1.

	 4.	 •	 Subtract bit by bit, 
borrowing, if necessary.

	 	 •	 Use binary subtraction 
rules like 1-0=1, 1-1=0, and 
borrowing, if needed from 
higher bits.

	 5.	 Because electronic devices 
operate with two states (on and 
off), binary (0 and 1) makes 
it easy to represent data and 
operations.

F.	 Assertion-Reason Based Questions:
	 1.	 (a)	 Both Assertion and Reason 

are true, and Reason is 
the correct explanation of 
Assertion.

	 	 (b)	 Both Assertion and Reason 
are true, and Reason is 
the correct explanation of 
Assertion.

G.	 Source-Based Questions:
	 1.	 Suggest him ways to do so →
	 •	 Divide 6 by 2 → quotient 3, 

remainder 0
	 •	 Divide 3 by 2 → quotient 1, 

remainder 1
	 •	 Divide 1 by 2 → quotient 0, 

remainder 1
	 •	 Read remainders from bottom 

to top: 110
	 	 Thus, 6 in decimal = 110 in 

binary.
Art and Integration
	 Do yourself.

3. Mastering Data: A Journey 
Through Database Management

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (d)	 All of the above
	 2.	 (b)	 Link two tables together
	 3.	 (c)	 Flat-file
	 4.	 (b)	 Primary Key
	 5.	 (b)	 Oracle
B.	 Fill in the blanks:
	 1.	 primary
	 2.	 integrity
	 3.	 tables
	 4.	 Foreign
	 5.	 data sheet
C.	 True or False:
	 1.	 False	 2. True
	 3.	 False	 4. False
	 5.	 True
D.	 Match the Columns:
	 1. (d), 2. (b), 3. (c), 4. (a).
E.	 Questions and Answers:
	 1.	 A database is an organized 

collection of data for easy 
access and management.

	 	 Example: A school library 
catalog storing book details like 
title, author, and publication 
year.

	 2.	 DBMS acts as an intermediary 
between the user and the 
database. It helps to store, 
retrieve, update, and manage 
data efficiently, while ensuring 
security and integrity.

	 3.	 •	 Primary Key: Uniquely 
identifies each record in a 
table.

	 	 •	 Foreign Key: Refers 
to the primary key of 
another table to establish 
a relationship between 
tables.

	 4.	 Three advantages of using a 
DBMS are:
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	 	 1.	 Faster Information Retrieval
	 	 •	 Quick Access: Through 

the use of queries, a DBMS 
allows for rapid retrieval 
of information. This speed 
is crucial for applications 
requiring immediate access 
to data, such as online 
transactions or reporting 
systems.

	 	 2.	 Support for Concurrent 
Updates

	 	 •	 Simultaneous Access: 
Multiple users can update 
the database at the same 
time without causing 
conflicts or data corruption. 
The DBMS manages these 
concurrent updates to 
ensure data consistency 
and accuracy.

	 	 3.	 Recovery of Data
		  •	 Data Protection: In the 

event of a system failure, 
the DBMS provides 
mechanisms for data 
recovery, ensuring that 
information is not lost 
and can be restored to a 
previous state.

	 5.	 •	 Open MS Access 2021.
	 	 •	 Create a new table.
	 	 •	 Define fields (columns) and 

set field types.
	 	 •	 Set a primary key (eg : 

Student ID)
	 	 •	 Save the table.

F. 	 Assertion-Reason Based Questions:
	 1.	 (b)	 Both A and R are true, 

but R is not the correct 
explanation of A.

	 	 	 (Controlled redundancy 
is because of centralized 
storage, not concurrent 
access.)

	 2.	 (d)	 A is false, but R is true.
	 	 	 (Primary key cannot have 

duplicates; Foreign key is 

used to link tables.)
G.	 Source-Based Questions:
	 •	 Primary Key:
	 	 →	 In the Student table: 

Student ID
	 	 →	 In the Department table: 

Dept. No.
	 •	 Foreign Key:
	 	 →	 In the Student table: Dept. 

No.
Art and Integration
	 Do yourself.

4. HTML Unveiled : The Building  
Blocks of the Web

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (a)	 <h1>
	 2.	 (b)	 href
	 3.	 (c)	 <p>
	 4.	 (c)	 <body style="background-

color:Red">
	 5.	 (c)	 <br>
B.	 Fill in the blanks:
	 1.	 <a>
	 2.	 <b>
	 3.	 <head>
	 4.	 style
	 5.	 <body>
C.	 True or False:
	 1.	 True	 2. False
	 3.	 True	 4. False
	 5.	 False
D.	 Questions and Answers:
	 1.	 HTML or Hyper Text 

Markup Language is not a 
programming language but a 
markup language. It describes 
the structure of web pages 
using tags. HTML allows 
web browsers to interpret 
and display text, images, 
videos, and other content in 
a meaningful and visually 
appealing way. It is important 
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because every web page on the 
internet is built using HTML.

	 2.	 The <p> tag is used to define 
a paragraph in HTML. It is a 
block-level element used to 
display blocks of text.

	 3.	 To create a hyperlink, use the 
<a> tag with the href attribute. 
Example:

	 	 <a href="https://www.google.
com">Go to Google</a>

	 4.	 •	 Block-level elements start 
on a new line and take up 
the full width available. 
Examples: <h1>, <p>, <div>.

	 	 •	 Inline elements only 
take up as much width as 
necessary and do not start 
on a new line. Examples: 
<span>, <a>, <img>.

	 5.	 You can change the background 
color by using the style attribute 
inside the <body> tag. Example: 
<body style"background-color: 
lightblue;">

E.	 1.	 (c)	 The assertion is correct, but 
the reason is incorrect.

	 2.	 (c)	 The assertion is correct, but 
the reason is incorrect.

F.	 Source Based Question
	 1.	 Title (Appears in the browser 

tab): The browser tab will show 
"My Favorite Hobby" — this is 
defined inside the <title> tag in 
the <head> section.

	 2.	 Main Heading on the Webpage: 
On the actual webpage, a large 
bold heading "Painting" will 
appear. This is displayed using 
the <h1> tag.

	 3.	 Paragraph Text: Just below 
the heading, a paragraph 
will be shown with the text: 
"I love painting landscapes and 
portraits. My favorite medium 
is watercolor."

	 	 This is enclosed within the <p> 
(paragraph) tag.

	 4.	 Hyperlink (Clickable Text):
	 	 Below the paragraph, a 

clickable link will appear with 
the text: "View My Gallery" 
When clicked, this link will 
take the user to:

	 https://www.example.com/gallery
	 	 This is created using the <a> 

(anchor) tag with the href 
attribute.

Art and Integration
	 Do yourself.

5. Crafting Web Magic: Based on 
HTML

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (b)	 <!--,-->
	 2.	 (a)	 alt
	 3.	 (b)	 <ol>
	 4.	 (c)	 href="ht tps : / /example .

com">Click here</a>
	 5.	 (b)	 bgcolor
B.	 Fill in the blanks:
	 1.	 <ul>
	 2.	 <!--, -->
	 3.	 URL
	 4.	 src
	 5.	 ordered, unordered
C.	 True or False:
	 1.	 False	 2. False
	 3.	 True	 4. True
	 5.	 False
D.	 Questions and Answers:
	 1.	 The comment tag is used to 

insert notes in the HTML code 
that are not displayed in the 
browser. It helps developers 
understand the structure and 
purpose of the code.

	 2.	 By using the <ol> tag. Example:
	 	 html
	 	 CopyEdit
	 	 <ol>
	 	 	 <li>Item 1</li>
	 	 	 <li>Item 2</li>
	 	 </ol>
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	 3.	 Attributes of the <img> tag.
	 .	 •	 src: The URL or file path of 

the image.
	 	 •	 alt: Descriptive text 

displayed if the image 
doesn't load.

	 	 •	 width: The width of the 
image  (in pixels).

	 	 •	 height: The height of the 
image (in pixels).

	 	 •	 title: Text that appears 
when you hover over the 
image.

	 4.	 External links point to another 
website using a full URL. 
Internal links navigate to 
sections within the same page 
or to another page on the same 
website.

	 5.	 A nested list is a list inside 
another list, often used to 
represent subcategories or 
hierarches.

E.	 Assertion-Reason Based Questions:
	 (a)	 Both assertion and reason are 

correct, and the reason explains 
the assertion.

	 (c)	 The assertion is correct, but the 
reason is incorrect.

F.	 Source-Based Questions:
1.	 Attributes of the <img> tag and 

their purpose:
	 •	 src="https://example.com/html. 

jpg" specifies the image source.
	 •	 alt="HTML Image" provides 

alternative text if the image 
doesn't load.

2.	 Paragraph-based questions:
	 1.	 Hyper Text Markup Language.
	 2.	 HTML is the standard markup 

language for creating web 
pages. It describes the structure 
of a page and uses elements 
to define how content is 
displayed.

	 3.	 Tim Berners Lee.
Art and Integration
	 Do yourself.

6. Python Basics : Your First Step 
into Python

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (c)	 Complex Syntax
	 2.	 (b)	 8
	 3.	 (b)	 variable_1
	 4.	 (b)	 = =
	 5.	 (b)	 import math
B.	 Fill in the blanks:
	 1.	 #
	 2.	 BODMAS
	 3.	 Float
	 4.	 displaying
	 5.	 object
C.	 True or False:
	 1.	 False	 2.	 True
	 3.	 True	 4.	 False
	 5.	 False
D.	 Match the Columns:
	 1.	 (d)	 	 2.	 (a)
	 3.	 (e)	 	 4.	 (b)
	 5.	 (c)
E.	 1.	 • �Interactive Mode: You enter 

code directly into the Python 
interpreter and get immediate 
result.

	 	 • �Script Mode: You write 
Python code in a file with a .py 
extension and run the entire 
script.

	 2.	 �A syntax error happens when 
Python code violates grammar 
rules.

	 Example:
	 python
	 Copy Edit
	 print ("Hello) # Missing closing quote
	 This produces :
	 typescript
	 CopyEdit
	 SyntaxError : EOL while scanning 

string literal
	 3.	 Comparison operators compare 

two values and return True of 
False.
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	 Examples :
	 	 • �= = : Checks if two values are 

equal → 5 = = 5 → True
	 	 • �! = : Checks if two values are not 

equal 5 → ! = 3 → True
	 	 • �> : Checks if one value is greater 

than the other : → 5 > 3 → True
	 4.	 A variable is a container for 

storing data values.
	 	 x = 5
	 	 name = "Alice"
	 	 print (x, name) # output : 5 

Alice
	 5.	 1. Install Python and open 

IDLE from the Start Menu.
	 	 2. Click of File > New File to 

open the editor.
	 	 3. Write Python code and save 

it with a .py extension.
	 	 4. Press F5 or click Run > Run 

Module to execute the script.
F.	 Assertion-Reason Based Questions:
	 1.	 (a)	 Both Assertion and Reason 

are true, and Reason is the 
correct explanation of the 
Assertion.

	 2.	 (c)	 Assertion it true, but 
Reason is false.

G.	 Source 1:
	 1. 	 x is less than y
	 2.	 python
	 	 CopyEdit
	 	 x = 20
	 	 y = 10
	 	 if x > y :
	 	 print ("x is greater than y")
	 else :
	 	 print ("x is not greater than y")
	 Source 2:
	 1.	 result = 15 + 2 – 2 = 15
	 2.	 result = 5 * (3 + 2) – 4 / 2
	 	 This changes the order to :
	 	 5 * 5 – 2 = 25 – 2 = 23
Art and Integration
	 Do yourself.

7. Deep Dive into Python : 
Expanding Your Coding

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (c)	 Conditional statement
	 2.	 (b)	 Greater
	 3.	 (b)	 B
	 4.	 (c)	 break
	 5.	 (b)	 while loop
B.	 Fill in the blanks:
	 1.	 True	 2.	 if
	 3.	 break	 4.	 while
	 5.	 elif
C.	 True or False:
	 1.	 False	 2.	 True
	 3.	 True	 4.	 True
	 5.	 False
D.	 Match the Cojumns:
	 1.	 (d)	 	 2.	 (c)
	 3.	 (e)	 	 4.	 (b)
	 5.	 (a)
E.	 Questions and Answers:
	 1.	 To execute a block of code only 

when a specific condition is 
true.

	 2.	 if executes code when the 
condition is true; if...else 
handles both true and false 
outcomes.

	 3.	 To repeatedly execute a block 
of code as long as the condition 
remains true.

	 4.	 When you need to check 
multiple conditions after the 
initial if.

	 5.	 It immediately exits the loop, 
even if the loop condition is 
still true.

F.	 1.	 (c)	 Assertion is true, but 
Reason is false.

	 2.	 (c)	 Assertion is true, but 
Reason is false.

G.	 Source-Based Questions
	 1.	 (a)	 Output : Equal to 5
		  (b)	 Explanation : Because x = = 

5 is ture, so the elif block is 
executed.

	 2.	 (a)	 Value of counter when 
loop stops : 3
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		  (b)	 Loop executes : 2 times (for 

counter = 1 and 2) 
Art and Integration
	 Do yourself.

8. Cloudy With a Chance of 
Computing : An Introduction to 

Cloud Computing

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (c)	 Distributed Cloud
	 2.	 (a)	 Software as a Service
	 3.	 (b)	 PaaS
	 4.	 (b)	 2006
	 5.	 (c)	 Security Concerns
B.	 Fill in the blanks:
	 1.	 demand
	 2.	 Hybrid Cloud
	 3.	 Amazon	 4.	 cost
	 5.	 SaaS
C.	 True or False:
	 1.	 False	 2.	 True
	 3.	 False	 4.	 False
	 5.	 True
D.	 Questions and Answers:
	 1.	 Cloud computing offers 

scalable, on-demand services 
charged by usage and includes 
tools beyond hosting, while 
traditional hosting provides 
fixed resources with a fixed 
charge.

	 2.	 Infrastructure as a Service 
(IaaS) provides virtualized 
computing resources like 
service and storage over the 
internet.

	 3.	 Scalability : Easily scale 
resources up or down based on 
demand.

		  Cost Efficiency : Pay only 
for what you use, reducing 
the need for large capital 
expenditures.

		  Accessibility : Access services 
from anywhere with an internet 
connection.

	 4.	 A service offered over the 
public internet, available to 
anyone who wants to purchase 

them.
	 5.	 Storing patient records and 

telemedicine.
E.	 1.	 (a)	 Both Assertion and Reason 

are true, and Reason is 
the correct explanation of 
Assertion.

	 2.	 (d)	 Both Assertion and Reason 
are false.

F.	 1.	 Cloud computing refers to the 
delivery of computing services 
such as storage, servers, and 
software over the internet.

	 2.	 The approach of cloud 
computing.

Art and Integration.
	 Do yourself

9. Elevating the Clouds: Advance 
Concept of Cloud Computing

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (b)	 Low Latency
	 2.	 (c)	 Managing Servers Manually
	 3.	 (a)	 Data Encryption
	 4.	 (b)	 Predictive Analytics
	 5.	 (c)	 Complex Problem Solving
B.	 Fill in the blanks:
	 1.	 Edge
	 2.	 Serverless Computing
	 3.	 encryption
	 4.	 Artificial Intelligence
	 5.	 Quantum
C.	 True or False:
	 1.	 False	 2.	 False
	 3.	 True	 4.	 False
	 5.	 True
D.	 Short Answer Questions :
	 1.	 Edge Computing processes 

data closer to where it is 
generated, reducing latency, 
saving bandwidth, and 
improving efficiency, especially 
in real-time applications.

	 2.	 Serverless Computing is 
a model where the cloud 
provider manages resources 
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automatically, letting 
developers focus on code and 
pay only for compute time 
used.

	 3.	 Predictive Analytics: Al 
algorithms can predict future 
trends based on historical data.

	 	 Natural Language Processing 
(NLP) : Enables the creation of 
applications that understand 
and generate human language.

	 4.	 It uses quantum mechanics to 
perform complex calculations 
exponentially faster than 
traditional computers.

	 5.	 By using energy-efficient data 
centers, virtualization, and 
renewable energy to reduce 
environmental impact.

E.	 1.	 (a)	 Both A and R are true, and 
R is the correct explanation of 
A.

	 2.	 (d)	 A is false, but R is true.
F.	 Source-Based Questions
	 1.	 The main industries driving the 

adoption of Edge Computing 
are autonomous vehicles, smart 
grids, and industrial IoT.

	 2.	 Edge Computing contributes 
to real-time processing by 
processing data closer to where 
it is generated, which reduces 
latency, saves bandwidth, 
and improves the efficiency of 
cloud services.

Art and Integration.
	 Do yourself

10. The AI Revolution : Exploring 
the Future of Technology

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (b)	 Predictive analytics for 

early diagnosis
	 2.	 (b)	 Quantum Computing
	 3.	 (b)	 Internet of Things
	 4.	 (b)	 Data privacy
	 5.	 (b)	 Decentralized and 

transparent transaction

B.	 Fill in the blanks:
	 1.	 IoT
	 2.	 CRISPR–Cas9
	 3.	 qubits
	 4.	 Intelligent tutoring
	 5.	 Ethical concern
C.	 True or False:
	 1.	 False	 2.	 True
	 3.	 False	 4.	 False
	 5.	 False
D.	 Assertion-Reason Based Question :
	 1.	 (a) Both A and R are true, and R 

is the correct explanation of 
A.

	 2.	 (d)	 A is false, but R is true.
E.	 Source-Based Questions
	 1.	 Internet of Things.
	 2.	 Learning from the data they 

collect.
	 3.	 It manages and analyzes the 

vast amounts of data generated 
by IoT devices.

	 4.	 Smarter homes, cities, and 
healthcare systems.

	 5.	 By connecting to the internet.
Art and Integration.
	 Do yourself

Worksheet-1
A.	 Click () the correct option:
	 1.	 (a)	 0011
	 2.	 (b)	 Primary key
	 3.	 (c)	 Keyboard
	 4.	 (b)	 Bgcolor
	 5.	 (a)	 <b1>
B.	 Fill in the blanks:
	 1.	 style
	 2.	 <!-- , -->
	 3.	 monitor
	 4.	 datasheet
	 5.	 0, 1
C.	 True or False:
	 1.	 False	 2. True
	 3.	 False	 4. False
	 5.	 True
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D.	 1.	 To create a hyperlink, use the 

<a> tag with the href attribute. 
Example:

	 	 <a href="https://www.google.
com">Go to Google</a>

	 2.	 Supercomputers are used 
for specialized tasks such as 
scientific simulations, weather 
forecasting, and cryptography.

	 3.	 Tree advantages of using a 
DBMS are:

	 	 1.	 Faster Information Retrieal
	 		  Quick Access: Through 

the use of queries, a DBMS 
allows for rapid retrieval 
of information. This speed 
is crucial for applications 
requiring immediate access 
to data, such as online 
transactions or reporting 
systems.

	 	 2.	 Support for Concurrent 
Updates

	 		  Simultaneous Access: 
Multiple users can update 
the database at the same 
time without causing 
conflicts or data corruption. 
The DBMS manages these 
concurrent updates to 
ensure data consistency 
and accuracy.

	 	 3.	 Recovery of Data
			   Data Protection: In the 

event of a system failure, 
the DBMS provides 
mechanisms for data 
recovery, ensuring that 
information is not lost 
and can be restored to a 
previous state.

	 4.	 •	 Subtract bit by bit, 
borrowing if necessary.

	 	 •	 Use binary subtaction 
rules like 1-0=1, 1-1=0, and 
borrowing if needed from 
higher bits.

	 5.	 The <p> tag is used to define 
a paragraph in HTML. It is 

a block-level element used 
todisplay blocks of text.

Worksheet-2
A.	 Click () the correct option:
	 1.	 (b)	 Quantum Computing
	 2.	 (b)	 Import math
	 3.	 (c)	 Break
	 4.	 (a)	 Data Encryption
	 5.	 (c)	 Complex
B.	 Fill in the blanks:
	 1.	 SaaS	 2.	 Edge
	 3.	 qubits	 4.	 while
	 5.	 float
C.	 True or False:
	 1.	 False	 2.	 False
	 3.	 False	 4.	 True
	 5.	 False
D.	 1.	 (a)	 A syntax error occurs when 

the Python interpreter detects 
a violation of the Python 
grammar rules.

	 	 Example
	 	 print ("Hello) Missing closing 

quote
	 	 The interpreter will return :
	 	 syntaxError: EOL while 

scanning string literal
	 2.	 A service offered over the 

public internet, available to 
anyone who wants to purchase 
them.

	 3.	 Predictive Analytics: AI 
algorithms can predict future 
trends based on historical data.

	 	 Natural Language Processing 
(NLP) : Enables the creation of 
applications that understand 
and generate human language.

	 4.	 By using energy-efficient data 
centers, virtualization, and 
renewable energy to reduce 
environmental impact.

	 5.	 A service offered over the 
public internet, available to 
anyone who wants to purchase 
them.

oo
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1. Computer Networking

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (d)	 All of the above
	 2.	 (b)	 To connect different 

networks and manage data 
traffic

	 3.	 (b)	 Star Topology
	 4.	 (b)	 Wi-Fi
	 5.	 (d)	 WAN
B.	 Fill in the blanks:
	 1.	 switch
	 2.	 ring
	 3.	 MAC address
	 4.	 Computer
	 5.	 hub
C.	 True or False:
	 1.	 True	 2.	 False
	 3.	 False	 4.	 True
	 5.	 False
D.	 Questions and Answers:
	 1.	 Devices (computers, servers, 

networking devices), 
communication medium 
(wired and wireless), Network 
Interface Cards (NICs), 
protocols, switches, and 
routers.

	 2.	 If one cable fails, the other 
devices remain unaffected. 
It is easy to add new devices 
without disrupting the 
network.

	 3.	 Protocols are a set of rules 
that determine how data is 
transmitted over the network 
and ensure that devices can 
communicate effectively.

	 4.	 Wireless technologies like  
Wi-Fi and Bluetooth allow 
devices to connect without 
cables, providing flexibility, 

mobility, and enabling quick 
and easy connections, even on 
the move.

	 5.	 Single point of failure: If the 
server goes down, all clients 
lose access. High cost: Setting 
up and maintaining servers is 
expensive.

E.	 Assertion-Reason Questions:
	 1.	 (a)	 Both assertion and reason 

are true, and the reason is 
the correct explanation for 
the assertion.

	 2.	 (c)	 The assertion is true, but 
the reason is false.

F.	 Case-Based Question:
	 1.	 In star topology, if one cable 

fails, other devices remain 
unaffected. It is easier to add 
new devices and the network 
becomes more reliable and 
easier to maintain.

	 2.	 Higher cost due to more cabling 
and the need for a central hub 
or switch. The transition might 
cause temporary disruption 
while setting up the new 
structure.

Art Integration
	 Do yourself

2. Computer Crime and Ethics
Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (b)	 The moral principles 

governing the use of 
computers

	 2.	 (c)	 Virus
	 3.	 (c)	 Deceiving users into 

providing personal 
information

	 4.	 (a)	 Commandment 1
	 5.	 (b)	 Frequent crashes and slow 

speed
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B.	 Fill in the Blanks:
	 1.	 moral
	 2.	 worm
	 3.	 Spam
	 4.	 Cyberbullying
	 5.	 firewall
C.	 True/False:
	 1.	 True	 2.	 True
	 3.	 False	 4.	 True
	 5.	 False
D.	 Question and Answer:
	 1.	 The Ten Commandments 

of Computer Ethics are 
a set of guidelines that 
promote responsible and 
respectful behavior in digital 
environments.

	 	 •	 Commandment 1: Thou 
shalt not use a computer to 
harm other people.

	 	 •	 Commandment 3: Thou 
shalt not snoop around in 
other people's computer 
files.

	 	 •	 Commandment 6: Thou 
shalt not copy or use 
proprietary software for 
which you have not paid.

	 2.	 Phishing involves sending fake 
emails or messages pretending 
to be from trustworthy sources 
to trick users into sharing 
personal information.

	 	 Pharming redirects users from 
legitimate websites to fake 
ones without their knowledge, 
usually by altering DNS 
settings.

	 3.	 •	 Install antivirus software
	 	 •	 Perform regular system 

scans
	 	 •	 Enable real-time protection
	 	 •	 Be cautious with 

downloads
	 	 •	 Backup data regularly

	 4.	 A firewall is a security system 
that monitors and controls 
incoming and outgoing 
network traffic based on 
security rules. It helps prevent 
unauthorized access to systems 
and data.

	 5.	 Cyberbullying is the use 
of technology to harass, 
intimidate, or harm others. 
It can occur through social 
media, messaging apps, or 
online games and may lead to 
anxiety, depression, and even 
suicidal thoughts.

E.	 Assertion-Reason Questions:
	 1.	 (a)	 Both assertion and reason 

are true, and the reason is 
the correct explanation for 
the assertion.

	 2.	 (d)	 The assertion is false, but 
the reason is true.

F.	 Case-Based Question:
	 •	 Do not click the link: It might 

redirect to a fraudulent website 
(pharming).

	 •	 Verify the source: Check 
the sender’s email address 
carefully.

	 •	 Contact the bank directly: 
Use a trusted phone number 
or website, not the link in the 
email.

	 •	 Report the email: Report to a 
parent, teacher, or cybercrime 
cell.

	 •	 Delete the message: Remove 
the risk of accidentally clicking 
it later.

Art Integration
	 Do yourself

3. Understanding HTML 
Attributes and CSS Selectors

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (b)	 href
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	 2.	 (b)	 #idName
	 3.	 (a)	 *
	 4.	 (c)	 <link rel="stylesheet" 

href="stylesheet.css">
	 5.	 (b)	 Class selector
B.	 Fill in the Blanks:
	 1.	 href
	 2.	 Cascading Style Sheets
	 3.	 class
	 4.	 style
	 5.	 link
C.	 True/False:
	 1.	 False	 2.	 True
	 3.	 False	 4.	 True
	 5.	 True
D.	 Question and Answer:
	 1.	 HTML attributes provide 

additional information about 
HTML elements. They are 
always included in the opening 
tag and usually come in name/
value pairs like name="value".

	 2.	 CSS selectors are used to select 
and style HTML elements 
based on their attributes, id, 
class, or type.

	 3.	 The ID selector targets a specific 
element with a unique id, while 
the Class selector can be used 
for multiple elements sharing 
the same class name.

	 4.	 Inline styles are applied directly 
to elements using the style 
attribute. External stylesheets 
are separate CSS files linked to 
the HTML document using the 
<link> tag.

	 5.	 By using the <link 
rel="stylesheet" href="style.
css"> tag inside the <head> 
section of the HTML document.

E.	 Assertion-Reason Questions:
	 1.	 (d)	 The assertion is false, but 

the reason is true.
	 2.	 (a)	 Both assertion and reason 

are true, and the reason is 
the correct explanation for 
the assertion.

F.	 Case-Based Question:
	 1.	 <link rel="stylesheet" 

href="style.css">
	 2.	 Use a class attribute like 

class="product" in both <div> 
and <p> tags and define 
product in the CSS.

	 3.	 No, because the ID must be 
unique within a page and 
cannot be used for multiple 
elements.

Art Integration
       Do yourself

4. Developing Interactive Web 
Pages

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (d) All of the above
	 2.	 (b) prompt()
	 3.	 (b) onclick
	 4.	 (c) parseInt("25")
	 5.	 (a) alert()
B.	 Fill in the Blanks:
	 1.	 const
	 2.	 toString()
	 3.	 onmouseover
	 4.	 function
	 5.	 onkeydown
C.	 True/False:
	 1.	 True	 2.	 False
	 3.	 True	 4.	 False
	 5.	 True
D.	 Question and Answer:
	 1.	 Variables in JavaScript store 

data that can be used and 
manipulated throughout the 
program.

	 2.	 JavaScript supports basic 
arithmetic operations such as 
Addition (+), Subtraction (-), 
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Multiplication (*), Division (/), 
and Modulus (%).

	 3.	 JavaScript provides the 
parseInt() function to convert 
strings into integers.

	 4.	 JavaScript listens for onclick 
events on buttons and executes 
the appropriate function.

	 5.	 The onmouseover event is 
triggered when the user hovers 
the mouse over an element. The 
onmouseout event is triggered 
when the mouse leaves the 
element.

E.	 Assertion-Reason Questions:
	 1.	 (a)	 Both assertion and reason 

are true, and the reason is 
the correct explanation for 
the assertion.

	 2.	 (b)	 Both assertion and reason 
are true, but the reason is 
not the correct explanation 
for the assertion.

F.	 Case-Based Question:
	 1.	 alert()
	 2.	 onclick
	 3.	 By using JavaScript to update 

the content dynamically 
without reloading the page.

Art Integration
       Do yourself

5. Turtle Programming in Python
Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (c)	 pensize()
	 2.	 (a)	 fillcolor(), begin_fill(), end_

fill()
	 3.	 (c)	 clear()
	 4.	 (b)	 my_turtle.circle(50, 180)
	 5.	 (b)	 Leaves a copy of the 

turtle's shape at its current 
position.

B.	 Fill in the Blanks:
	 1.	 import turtle

	 2.	 speed
	 3.	 bye()
	 4.	 clone
	 5.	 four
C.	 True/False:
	 1.	 True
	 2.	 False
	 3.	 True
	 4.	 True
	 5.	 True
D.	 Question and Answer:
	 1.	 You can fill shapes with color 

using the fillcolor(), begin_fill(), 
and end_fill() methods.

	 2.	 You can easily draw circles 
using the circle() method, 
which takes the radius as an 
argument.

	 3.	 To create parallel lines, you can 
lift the pen up and reposition 
the turtle without drawing. This 
is achieved using the penup() 
and pendown() methods.

	 4.	 •	 If you want to clear all 
drawings from the screen 
without closing the Turtle 
graphics window, you can 
use the clear() method.

	 	 •	 To reset the turtle's position 
and clear the screen 
completely, use the reset() 
method.

	 5.	 You can use the fillcolor() 
method to set the color and the 
pensize() method to change the 
thickness of the lines drawn by 
the turtle.

E.	 Assertion-Reason Questions:
	 1.	 (a)	 Both assertion and reason 

are true, and the reason is 
the correct explanation for 
the assertion.

	 2.	 (b)	 Both assertion and reason 
are true, but the reason is 
not the correct explanation 
for the assertion.
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F.	 Case-Based Question:
	 To draw a star shape using Turtle 

graphics, the student should 
change the turning angle to 144 
degrees instead of 60. The turtle 
should repeat the forward(100) and 
right(144) commands five times 
to complete the five-pointed star. 
The correct angle for a regular five-
pointed star is 144°.

Art Integration
	 Do yourself

6. "The Next-Gen Internet: 
Smarter, Faster, and 

Unstoppable!"
Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (b)	 IoT
	 2.	 (c)	 Quantum Internet
	 3.	 (b)	 A 3D digital universe
	 4.	 (c)	 Brain-Computer Interface
	 5.	 (b)	 Space Internet
B.	 Fill in the Blanks:
	 1.	 Artificial Intelligence
	 2.	 5D Internet
	 3.	 Internet of Things
	 4.	 Holographic Communication
	 5.	 Metaverse
C.	 True/False:
	 1.	 True	 2.	 False
	 3.	 True	 4.	 False
	 5.	 True
D.	 Question and Answer:
	 1.	 This is all possible with the 

Internet of Things (IoT), where 
everyday objects are connected 
to the internet, making life 
easier and smarter.

	 2.	 The future of the internet 
will be powered by Artificial 
Intelligence (AI), making search  
engines smarter, voice assistants 
sharper, and recommendations 

more personalized.
	 3.	 With super-speed internet, 

video calls will feel as real as 
face-to-face conversations, and  
online gaming will have 
zero lag. The possibilities are 
endless!

	 4.	 Smart Cities will use sensors, 
AI, and real-time data to 
control traffic lights, monitor 
air quality, and even manage 
electricity usage efficiently.

	 5.	 Brain-Computer Interface 
(BCI) technology is being 
developed to connect human 
brains directly to the internet. 
This could help people with 
disabilities control devices 
using only their thoughts.

F.	 Case-Based Question:
	 1.	 (b)	 Artificial Intelligence
	 2.	 (a)	 By providing customized 

lessons and instant 
feedback

	 3.	 (b) 	Holographic 
Communication

Art Integration
       Do yourself

7. Artificial Intelligence and  
Its Application

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (b)	 To create systems that can 

perform tasks requiring 
human intelligence

	 2.	 (c)	 American Psychological 
Association (APA)

	 3.	 (b)	 Narrow AI
	 4.	 (b)	 Diagnosing diseases from 

medical images
	 5.	 (b)	 A machine's ability to 

exhibit intelligent behavior 
similar to a human

B.	 Fill in the Blanks:
	 1.	 computer science
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	 2.	 learning
	 3.	 Narrow
	 4.	 Turing
	 5.	 reasoning
C.	 True/False:
	 1.	 False	 2.	 True
	 3.	 True	 4.	 False
	 5.	 False
D.	 Question and Answer:
	 1.	 Artificial Intelligence (AI) is a 

branch of computer science that 
focuses on creating systems 
capable of performing tasks 
that typically require human 
intelligence.

	 2.	 •	 Data Privacy
	 	 •	 Bias and Fairness
	 3.	 •	 Learning
	 	 •	 Reasoning
	 	 •	 Problem Solving
	 4.	 •	 Narrow AI refers to 

systems designed to 
perform specific tasks.

	 	 •	 General AI refers to a 
hypothetical type of AI that 
can understand, learn, and 
apply knowledge across 
a wide range of tasks, 
similar to human cognitive 
abilities.

	 5.	 •	 The Turing Test is a 
measure of a machine's 
ability to exhibit intelligent 
behavior indistinguishable 
from that of a human.

	 	 •	 It serves as a benchmark 
for AI and pushes research 
in machine learning 
and natural language 
processing.

E.	 Assertion-Reason Questions:
	 1.	 (a)	 Both assertion and reason 

are true, and the reason is 
the correct explanation for 
the assertion.

	 2.	 (d)	 The assertion is false, but 

the reason is true.
F.	 Case-Based Question:
	 Benefits:
	 •	 AI algorithms can analyze 

medical images to detect 
anomalies like tumors or 
fractures.

	 •	 AI improves early diagnosis 
and treatment effectiveness.

	 Challenge:
	 •	 Data Privacy
	 How to address the challenge:
	 •	 Ensuring data protection 

measures are in place is 
essential to maintain user trust.

Art Integration:
      Do yourself

8. Robotics
Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (b)	 A programmable machine 

that can perform tasks 
automatically

	 2.	 (c)	 Industrial robots
	 3.	 (c)	 Actuators
	 4.	 (b)	 Ultrasonic Sensor
	 5.	 (c)	 Limited applications
B.	 Fill in the Blanks:
	 1.	 computer
	 2.	 Service
	 3.	 power supply
	 4.	 sensors
	 5.	 Turing
C.	 True/False:
	 1.	 False	 2.	 False
	 3.	 True	 4.	 True
	 5.	 False
D.	 Question and Answer:
	 1.	 Power Supply, Microcontroller, 

Sensors, Actuators, Chassis.
	 2.	 •	 Industrial Robots: Used 

in manufacturing and 
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assembly lines for tasks like 
welding and packaging.

	 	 •	 Medical Robots: Assist in 
surgeries, rehabilitation, 
and patient care.

	 3.	 Sensors help robots perceive 
their environment, such as 
measuring distance, detecting 
heat, and capturing images or 
videos.

	 4.	 Programming enables robots 
to perform tasks, respond to 
sensors, and make decisions. 
It is essential for robot 
functionality.

	 5.	 Safety Concerns, High Costs, 
Complexity of Programming, 
Ethical Issues.

E.	 Assertion-Reason Questions:
	 1.	 (a)	 Both assertion and reason 

are true, and the reason is 
the correct explanation for 
the assertion.

	 2.	 (d)	 The assertion is false, but 
the reason is true.

F.	 Case-Based Question:
	 Benefits:
	 •	 Robots can work continuously 

without fatigue, improving 
productivity.

	 •	 They can reduce human 
error and handle repetitive or 
hazardous tasks.

	 Challenges:
	 •	 Safety concerns when working 

alongside humans.
	 •	 High development and 

implementation costs.
	 •	 Complexity in programming 

robots to adapt to dynamic 
environments.

Art Integration:
	 Do yourself

9. Green Computing– The Future 
of Sustainable Technology

Skill Sharpeners
A.	 Click () the correct option:
	 1.	 (b)	 Reduce environmental 

impact of technology
	 2.	 (c)	 Using energy-efficient 

hardware
	 3.	 (c)	 Fossil fuels
	 4.	 (b)	 Reduces reliance on 

physical hardware
	 5.	 (b)	 Designing energy-efficient 

components
B.	 Fill in the blanks:
	 1.	 Green Computing
	 2.	 electricity
	 3.	 Cloud
	 4.	 solar
	 5.	 electronic
C.	 True/False:
	 1.	 False	 2.	  True
	 3.	 False	 4.	 True
	 5.	 False
D.	 Question and Answer:
	 1.	 Green computing refers to the 

environmentally responsible 
use of computers and 
related resources. It includes 
designing, using, and disposing 
of hardware and software in 
ways that reduce their impact 
on the environment.

	 2.	 •	 Saves energy and reduces 
electricity bills.

	 	 •	 Reduces harmful electronic 
waste.

	 	 •	 Helps in fighting global 
warming by lowering 
pollution.

	 	 •	 Increases the lifespan of 
electronic devices.

	 	 •	 Encourages the 
development of eco-
friendly technologies.

	 3.	 Lowering energy use reduces 
reliance on fossil fuels, 
cutting down pollution and 
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greenhouse gases. Reducing 
electronic waste minimizes 
toxic materials entering the 
environment and promotes 
recycling and reuse.

	 4.	 Green Computing saves 
energy, reduces pollution, and 
minimizes waste. This protects 
natural resources, reduces 
global warming, and ensures a 
cleaner and safer environment 
for future generations.

	 5.	 The future of Green Computing 
includes the use of solar-
powered and biodegradable 
devices, energy-saving 
hardware and software, 
smart recycling methods, AI-
driven energy solutions, and 
increased use of green data 
centers and cloud technologies. 
These innovations aim to make 
technology more sustainable.

E.	 Assertion-Reason Questions:
	 1.	 (a)	 Both A and R are true, and 

R is the correct explanation 
of A.

	 2.	 (d)	 A is false, but R is true.
F.	 Case-Based Question:
	 1.	 It reduces the need for paper, 

saving trees and lowering 
environmental impact from 
printing.

	 2.	 Solar energy is renewable and 
clean, reducing dependence 
on fossil fuels and cutting 
electricity costs.

	 3.	 It prevents harmful materials 
from polluting the environment 
and conserves resources by 
reusing components.

	 4.	 The school can encourage 
students and staff to turn off 
devices when not in use to save 
energy.

Art Integration
	 Do yourself

Worksheet-1
A.	 Click () the correct option:
	 1.	 (b)	 Star Topology
	 2.	 (c)	 Virus
	 3.	 (a)	 *
	 4.	 (c)	 parselnt("25")
	 5.	 (b)	 my_turtle.circle(50, 180)
B.	 Fill in the blanks:
	 1.	 switch	 2.	 moral
	 3.	 class	 4.	 const
	 5.	 speed
C.	 True or False:
	 1.	 False	 2.	 True
	 3.	 False	 4.	 False
	 5.	 True
D.	 Answer the following questions:
	 1.	 Protocols are a set of rules 

that determine how data is 
transmitted over the network 
and ensure that devices can 
communicate effectively.

	 2.	 Cyberbullying is the use 
of technology to harass, 
intimidate, or harm others. 
It can occur through social 
media, messaging apps, or 
online games and may lead to 
anxiety, depression, and even 
suicidal thoughts.

	 3.	 CSS selectors are used to select 
and style HTML elements 
based on their attributes, id, 
class, or type.

	 4.	 Variables in JavaScript store 
data that can be used and 
manipulated throughout the 
program.

	 5.	 •	 If you want to clear all 
drawings from the screen 
without closing the Turtle 
graphics window, you can 
use the clear() method.

	 	 •	 To reset the turtle's position 
and clear the screen 
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completely, use the reset() 
method.

E.	 Assertion-Reason Questions:
	 1.	 (a)	 Both assertion and reason 

are true, and the reason is 
the correct explanation for 
the assertion.

	 2.	 (d)	 The assertion is false, but 
the reason is true.

	 3.	 (d)	 The assertion is false, but 
the reason is true.

	 4.	 (b)	 Both assertion and reason 
are true, but the reason is 
not the correct explanation 
for the assertion.

	 5.	 (a)	 Both assertion and reason 
are true, and the reason is 
the correct explanation for 
the assertion.

Worksheet-2
A.	 Click () the correct option:
	 1.	 (c)	 Quantum Internet
	 2.	 (b)	 Narrow AI
	 3.	 (c)	 Industrial robots
	 4.	 (c) Limited application
	 5.	 (c)	 Fossil fuels
B.	 Fill in the blanks:
	 1.	 Artificial Intelligence
	 2.	 Narrow
	 3.	 Service
	 4.	 Turing
	 5.	 electricity
C.	 True or False:
	 1.	 False	 2.	 False
	 3.	 False	 4.	 False
	 5.	 False
D.	 Answer the following questions:
	 1.	 This is all possible with the 

Internet of Things (IoT), where 
everyday objects are connected 
to the internet, making life 
easier and smarter.

	 2.	 Artificial Intelligence (AI) is a 
branch of computer science that 
focuses on creating systems 
capable of performing tasks 
that typically require human 
intelligence.

	 3.	 Sensors help robots perceive 
their environment, such as 
measuring distance, detecting 
heat, and capturing images or 
videos.

	 4.	 Safety Concerns, High Costs, 
Complexity of Programming, 
Ethical Issues.

	 5.	 Green computing refers to the 
environmentally responsible 
use of computers and 
related resources. It includes 
designing, using, and disposing 
of hardware and software in 
ways that reduce their impact 
on the environment.

E.	 Assertion-Reason Questions:
	 1.	 (a)	 Both assertion and reason 

are true, and the reason is 
the correct explanation for 
the assertion.

	 2.	 (d)	 The assertion is false, but 
the reason is true.

	 3.	 (a)	 Both assertion and reason 
are true, and the reason is 
the correct explanation for 
the assertion.

	 4.	 (d)	 The assertion is false, but 
the reason is true.

	 5.	 (a)	 Both assertion and reason 
are true, and the reason is 
the correct explanation for 
the assertion.

oo


